projects
/
openwrt
/
staging
/
hauke.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
04f29ee
)
kernel: add support for PD6729 PCMCIA bridge
author
Tomasz Maciej Nowak
<tomek_n@o2.pl>
Sat, 17 Dec 2016 21:00:45 +0000
(22:00 +0100)
committer
John Crispin
<john@phrozen.org>
Tue, 20 Dec 2016 08:35:36 +0000
(09:35 +0100)
New package kmod-pcmcia-pd6729 to support Cirrus Logic PD6729
PCI-to-PCMCIA bridge.
Signen-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
package/kernel/linux/modules/pcmcia.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/pcmcia.mk
b/package/kernel/linux/modules/pcmcia.mk
index 50a944c054886481483c511ba55aff24dfd5c374..b777573041ca4f45093a925cc7782f5b66407461 100644
(file)
--- a/
package/kernel/linux/modules/pcmcia.mk
+++ b/
package/kernel/linux/modules/pcmcia.mk
@@
-79,3
+79,19
@@
define KernelPackage/pcmcia-serial/description
endef
$(eval $(call KernelPackage,pcmcia-serial))
+
+
+define KernelPackage/pcmcia-pd6729
+ TITLE:=Cirrus PD6729 compatible bridge support
+ KCONFIG:=CONFIG_PD6729
+ FILES:=$(LINUX_DIR)/drivers/pcmcia/pd6729.ko
+ AUTOLOAD:=$(call AutoLoad,41,pd6729)
+ DEPENDS:=+kmod-pcmcia-rsrc
+ $(call AddDepends/pcmcia)
+endef
+
+define KernelPackage/pcmcia-pd6729/description
+ Kernel support for the Cirrus PD6729 PCI-to-PCMCIA bridge
+endef
+
+$(eval $(call KernelPackage,pcmcia-pd6729))