brcm2708: Add wifi driver, firmware and NVRAM for RPi1
authorDaniel Golle <daniel@makrotopia.org>
Wed, 20 Jun 2018 09:16:54 +0000 (11:16 +0200)
committerJo-Philipp Wich <jo@mein.io>
Tue, 18 Dec 2018 16:32:19 +0000 (17:32 +0100)
Apparently there are RPi1 devices with BRCM43430 wifi, such as the
Pi Zero W. Add the necessary packages for that to the image generated
for those boards as well.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
(backported from 969fe206bdb910789bebd064d4b3be00238b0012)

target/linux/brcm2708/image/Makefile

index 46590bf7a0a8410d97c7b27e5dd1f406c642c8ac..23dd478f8bf17527c4d483d13b5b88e44faf68ba 100644 (file)
@@ -58,6 +58,7 @@ define Device/rpi
   DEVICE_TITLE := Raspberry Pi B/B+/CM/Zero/ZeroW
   DEVICE_DTS := bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm bcm2708-rpi-0-w
   SUPPORTED_DEVICES := rpi-b rpi-b-plus rpi-cm rpi-zero rpi-zero-w raspberrypi,model-b raspberrypi,model-b-plus raspberrypi,compute-module-1 raspberrypi,model-b-rev2 raspberrypi,model-zero raspberrypi,model-zero-w
+  DEVICE_PACKAGES := brcmfmac-firmware-43430-sdio brcmfmac-board-rpi2 kmod-brcmfmac wpad-mini
 endef
 ifeq ($(SUBTARGET),bcm2708)
   TARGET_DEVICES += rpi