-Index: linux-2.6.25.4/arch/mips/Kconfig
-===================================================================
---- linux-2.6.25.4.orig/arch/mips/Kconfig
-+++ linux-2.6.25.4/arch/mips/Kconfig
-@@ -18,6 +18,24 @@ choice
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -18,6 +18,24 @@
prompt "System type"
default SGI_IP22
config MACH_ALCHEMY
bool "Alchemy processor based machines"
-Index: linux-2.6.25.4/arch/mips/kernel/traps.c
-===================================================================
---- linux-2.6.25.4.orig/arch/mips/kernel/traps.c
-+++ linux-2.6.25.4/arch/mips/kernel/traps.c
-@@ -1112,9 +1112,22 @@ void *set_except_vector(int n, void *add
+--- a/arch/mips/kernel/traps.c
++++ b/arch/mips/kernel/traps.c
+@@ -1112,9 +1112,22 @@
exception_handlers[n] = handler;
if (n == 0 && cpu_has_divec) {
}
return (void *)old_handler;
}
-Index: linux-2.6.25.4/arch/mips/Makefile
-===================================================================
---- linux-2.6.25.4.orig/arch/mips/Makefile
-+++ linux-2.6.25.4/arch/mips/Makefile
-@@ -167,6 +167,13 @@ libs-$(CONFIG_SIBYTE_CFE) += arch/mips/s
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -167,6 +167,13 @@
#
#
# Acer PICA 61, Mips Magnum 4000 and Olivetti M700.
#
core-$(CONFIG_MACH_JAZZ) += arch/mips/jazz/
-Index: linux-2.6.25.4/include/asm-mips/page.h
-===================================================================
---- linux-2.6.25.4.orig/include/asm-mips/page.h
-+++ linux-2.6.25.4/include/asm-mips/page.h
-@@ -182,8 +182,10 @@ typedef struct { unsigned long pgprot; }
+--- a/include/asm-mips/page.h
++++ b/include/asm-mips/page.h
+@@ -182,8 +182,10 @@
#define VM_DATA_DEFAULT_FLAGS (VM_READ | VM_WRITE | VM_EXEC | \
VM_MAYREAD | VM_MAYWRITE | VM_MAYEXEC)
-Index: linux-2.6.25.4/drivers/mtd/Kconfig
-===================================================================
---- linux-2.6.25.4.orig/drivers/mtd/Kconfig
-+++ linux-2.6.25.4/drivers/mtd/Kconfig
-@@ -168,6 +168,12 @@ config MTD_OF_PARTS
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -168,6 +168,12 @@
the partition map from the children of the flash node,
as described in Documentation/powerpc/booting-without-of.txt.
comment "User Modules And Translation Layers"
config MTD_CHAR
-Index: linux-2.6.25.4/drivers/mtd/Makefile
-===================================================================
---- linux-2.6.25.4.orig/drivers/mtd/Makefile
-+++ linux-2.6.25.4/drivers/mtd/Makefile
-@@ -12,6 +12,7 @@ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redbo
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -12,6 +12,7 @@
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
# 'Users' - code which presents functionality to userspace.
obj-$(CONFIG_MTD_CHAR) += mtdchar.o
-Index: linux-2.6.25.4/drivers/mtd/maps/physmap.c
-===================================================================
---- linux-2.6.25.4.orig/drivers/mtd/maps/physmap.c
-+++ linux-2.6.25.4/drivers/mtd/maps/physmap.c
-@@ -87,7 +87,8 @@ static int physmap_flash_remove(struct p
+--- a/drivers/mtd/maps/physmap.c
++++ b/drivers/mtd/maps/physmap.c
+@@ -87,7 +87,8 @@
static const char *rom_probe_types[] = { "cfi_probe", "jedec_probe", "map_rom", NULL };
#ifdef CONFIG_MTD_PARTITIONS
-Index: linux-2.6.25.4/drivers/char/Kconfig
-===================================================================
---- linux-2.6.25.4.orig/drivers/char/Kconfig
-+++ linux-2.6.25.4/drivers/char/Kconfig
-@@ -913,6 +913,15 @@ config MWAVE
+--- a/drivers/char/Kconfig
++++ b/drivers/char/Kconfig
+@@ -913,6 +913,15 @@
To compile this driver as a module, choose M here: the
module will be called mwave.
config SCx200_GPIO
tristate "NatSemi SCx200 GPIO Support"
depends on SCx200
-Index: linux-2.6.25.4/drivers/char/Makefile
-===================================================================
---- linux-2.6.25.4.orig/drivers/char/Makefile
-+++ linux-2.6.25.4/drivers/char/Makefile
-@@ -90,6 +90,7 @@ obj-$(CONFIG_COBALT_LCD) += lcd.o
+--- a/drivers/char/Makefile
++++ b/drivers/char/Makefile
+@@ -90,6 +90,7 @@
obj-$(CONFIG_PPDEV) += ppdev.o
obj-$(CONFIG_NWBUTTON) += nwbutton.o
obj-$(CONFIG_NWFLASH) += nwflash.o
-Index: linux-2.6.25.4/drivers/Kconfig
-===================================================================
---- linux-2.6.25.4.orig/drivers/Kconfig
-+++ linux-2.6.25.4/drivers/Kconfig
-@@ -97,4 +97,6 @@ source "drivers/dca/Kconfig"
+--- a/drivers/Kconfig
++++ b/drivers/Kconfig
+@@ -97,4 +97,6 @@
source "drivers/auxdisplay/Kconfig"
source "drivers/uio/Kconfig"
+
+source "drivers/vlynq/Kconfig"
endmenu
-Index: linux-2.6.25.4/drivers/Makefile
-===================================================================
---- linux-2.6.25.4.orig/drivers/Makefile
-+++ linux-2.6.25.4/drivers/Makefile
-@@ -91,5 +91,6 @@ obj-$(CONFIG_DCA) += dca/
+--- a/drivers/Makefile
++++ b/drivers/Makefile
+@@ -91,5 +91,6 @@
obj-$(CONFIG_HID) += hid/
obj-$(CONFIG_PPC_PS3) += ps3/
obj-$(CONFIG_OF) += of/
-Index: linux-2.6.25.4/drivers/net/cpmac.c
-===================================================================
---- linux-2.6.25.4.orig/drivers/net/cpmac.c
-+++ linux-2.6.25.4/drivers/net/cpmac.c
+--- a/drivers/net/cpmac.c
++++ b/drivers/net/cpmac.c
@@ -38,6 +38,7 @@
#include <linux/platform_device.h>
#include <linux/dma-mapping.h>
MODULE_AUTHOR("Eugene Konev <ejka@imfi.kspu.ru>");
MODULE_DESCRIPTION("TI AR7 ethernet driver (CPMAC)");
-@@ -207,6 +208,7 @@ struct cpmac_priv {
+@@ -207,6 +208,7 @@
struct work_struct reset_work;
struct platform_device *pdev;
struct napi_struct napi;
};
static irqreturn_t cpmac_irq(int, void *);
-@@ -455,6 +457,9 @@ static int cpmac_start_xmit(struct sk_bu
+@@ -455,6 +457,9 @@
struct cpmac_desc *desc;
struct cpmac_priv *priv = netdev_priv(dev);
if (unlikely(skb_padto(skb, ETH_ZLEN)))
return NETDEV_TX_OK;
-@@ -634,14 +639,14 @@ static void cpmac_clear_tx(struct net_de
+@@ -634,14 +639,14 @@
priv->desc_ring[i].dataflags = 0;
if (priv->desc_ring[i].skb) {
dev_kfree_skb_any(priv->desc_ring[i].skb);
struct cpmac_priv *priv =
container_of(work, struct cpmac_priv, reset_work);
-@@ -650,8 +655,47 @@ static void cpmac_hw_error(struct work_s
+@@ -650,8 +655,47 @@
spin_unlock(&priv->rx_lock);
cpmac_clear_tx(priv->dev);
cpmac_hw_start(priv->dev);
}
static irqreturn_t cpmac_irq(int irq, void *dev_id)
-@@ -682,49 +726,33 @@ static irqreturn_t cpmac_irq(int irq, vo
+@@ -682,49 +726,33 @@
cpmac_write(priv->regs, CPMAC_MAC_EOI_VECTOR, 0);
}
static int cpmac_ioctl(struct net_device *dev, struct ifreq *ifr, int cmd)
-@@ -911,6 +939,7 @@ static int cpmac_open(struct net_device
+@@ -911,6 +939,7 @@
goto fail_irq;
}
-Index: linux-2.6.25.4/drivers/net/Kconfig
-===================================================================
---- linux-2.6.25.4.orig/drivers/net/Kconfig
-+++ linux-2.6.25.4/drivers/net/Kconfig
-@@ -1874,7 +1874,7 @@ config SC92031
+--- a/drivers/net/Kconfig
++++ b/drivers/net/Kconfig
+@@ -1874,7 +1874,7 @@
config CPMAC
tristate "TI AR7 CPMAC Ethernet support (EXPERIMENTAL)"
drivers/net/cpmac.c | 19 +++----------------
2 files changed, 20 insertions(+), 16 deletions(-)
-Index: linux-2.6.25.4/arch/mips/ar7/platform.c
-===================================================================
---- linux-2.6.25.4.orig/arch/mips/ar7/platform.c
-+++ linux-2.6.25.4/arch/mips/ar7/platform.c
+--- a/arch/mips/ar7/platform.c
++++ b/arch/mips/ar7/platform.c
@@ -33,6 +33,8 @@
#include <linux/vlynq.h>
#include <linux/leds.h>
#include <asm/addrspace.h>
#include <asm/ar7/ar7.h>
-@@ -205,6 +207,13 @@ static struct physmap_flash_data physmap
+@@ -205,6 +207,13 @@
.width = 2,
};
static struct plat_cpmac_data cpmac_low_data = {
.reset_bit = 17,
.power_bit = 20,
-@@ -506,6 +515,10 @@ static int __init ar7_register_devices(v
+@@ -506,6 +515,10 @@
}
if (ar7_has_high_cpmac()) {
cpmac_get_mac(1, cpmac_high_data.dev_addr);
res = platform_device_register(&cpmac_high);
if (res)
-@@ -514,6 +527,10 @@ static int __init ar7_register_devices(v
+@@ -514,6 +527,10 @@
cpmac_low_data.phy_mask = 0xffffffff;
}
cpmac_get_mac(0, cpmac_low_data.dev_addr);
res = platform_device_register(&cpmac_low);
if (res)
-Index: linux-2.6.25.4/drivers/net/cpmac.c
-===================================================================
---- linux-2.6.25.4.orig/drivers/net/cpmac.c
-+++ linux-2.6.25.4/drivers/net/cpmac.c
-@@ -1035,23 +1035,10 @@ static int __devinit cpmac_probe(struct
+--- a/drivers/net/cpmac.c
++++ b/drivers/net/cpmac.c
+@@ -1035,23 +1035,10 @@
if (phy_id == PHY_MAX_ADDR) {
if (external_switch || dumb_switch) {
-Index: linux-2.6.25.4/drivers/net/cpmac.c
-===================================================================
---- linux-2.6.25.4.orig/drivers/net/cpmac.c
-+++ linux-2.6.25.4/drivers/net/cpmac.c
-@@ -187,6 +187,7 @@ struct cpmac_desc {
+--- a/drivers/net/cpmac.c
++++ b/drivers/net/cpmac.c
+@@ -187,6 +187,7 @@
#define CPMAC_EOQ 0x1000
struct sk_buff *skb;
struct cpmac_desc *next;
dma_addr_t mapping;
dma_addr_t data_mapping;
};
-@@ -242,6 +243,16 @@ static void cpmac_dump_desc(struct net_d
+@@ -242,6 +243,16 @@
printk("\n");
}
static void cpmac_dump_skb(struct net_device *dev, struct sk_buff *skb)
{
int i;
-@@ -413,21 +424,40 @@ static struct sk_buff *cpmac_rx_one(stru
+@@ -413,21 +424,40 @@
static int cpmac_poll(struct napi_struct *napi, int budget)
{
struct sk_buff *skb;
skb = cpmac_rx_one(priv, desc);
if (likely(skb)) {
netif_receive_skb(skb);
-@@ -436,19 +466,81 @@ static int cpmac_poll(struct napi_struct
+@@ -436,19 +466,81 @@
desc = desc->next;
}
}
static int cpmac_start_xmit(struct sk_buff *skb, struct net_device *dev)
-@@ -625,8 +717,10 @@ static void cpmac_clear_rx(struct net_de
+@@ -625,8 +717,10 @@
desc->dataflags = CPMAC_OWN;
dev->stats.rx_dropped++;
}
}
static void cpmac_clear_tx(struct net_device *dev)
-@@ -928,9 +1022,12 @@ static int cpmac_open(struct net_device
+@@ -928,9 +1022,12 @@
desc->buflen = CPMAC_SKB_SIZE;
desc->dataflags = CPMAC_OWN;
desc->next = &priv->rx_head[(i + 1) % priv->ring_size];
-Index: linux-2.6.25.4/drivers/net/cpmac.c
-===================================================================
---- linux-2.6.25.4.orig/drivers/net/cpmac.c
-+++ linux-2.6.25.4/drivers/net/cpmac.c
-@@ -1178,9 +1178,7 @@ static int __devinit cpmac_probe(struct
+--- a/drivers/net/cpmac.c
++++ b/drivers/net/cpmac.c
+@@ -1178,9 +1178,7 @@
priv->msg_enable = netif_msg_init(debug_level, 0xff);
memcpy(dev->dev_addr, pdata->dev_addr, sizeof(dev->dev_addr));
-Index: linux-2.6.25.4/drivers/mtd/ar7part.c
-===================================================================
---- linux-2.6.25.4.orig/drivers/mtd/ar7part.c
-+++ linux-2.6.25.4/drivers/mtd/ar7part.c
+--- a/drivers/mtd/ar7part.c
++++ b/drivers/mtd/ar7part.c
@@ -34,6 +34,10 @@
#define LOADER_MAGIC1 le32_to_cpu(0xfeedfa42)
#define LOADER_MAGIC2 le32_to_cpu(0xfeed1281)
struct ar7_bin_rec {
unsigned int checksum;
unsigned int length;
-@@ -47,7 +51,8 @@ static int create_mtd_partitions(struct
+@@ -47,7 +51,8 @@
unsigned long origin)
{
struct ar7_bin_rec header;
unsigned int pre_size = master->erasesize, post_size = 0;
unsigned int root_offset = ROOT_OFFSET;
-@@ -66,7 +71,7 @@ static int create_mtd_partitions(struct
+@@ -66,7 +71,7 @@
do { /* Try 10 blocks starting from master->erasesize */
offset = pre_size;
master->read(master, offset,
if (!strncmp((char *)&header, "TIENV0.8", 8))
ar7_parts[1].offset = pre_size;
if (header.checksum == LOADER_MAGIC1)
-@@ -88,7 +93,7 @@ static int create_mtd_partitions(struct
+@@ -88,7 +93,7 @@
while (header.length) {
offset += sizeof(header) + header.length;
master->read(master, offset, sizeof(header),
}
root_offset = offset + sizeof(header) + 4;
break;
-@@ -96,10 +101,10 @@ static int create_mtd_partitions(struct
+@@ -96,10 +101,10 @@
while (header.length) {
offset += sizeof(header) + header.length;
master->read(master, offset, sizeof(header),
-Index: linux-2.6.25.4/drivers/serial/8250.c
-===================================================================
---- linux-2.6.25.4.orig/drivers/serial/8250.c
-+++ linux-2.6.25.4/drivers/serial/8250.c
-@@ -267,6 +267,13 @@ static const struct serial8250_config ua
+--- a/drivers/serial/8250.c
++++ b/drivers/serial/8250.c
+@@ -267,6 +267,13 @@
.fcr = UART_FCR_ENABLE_FIFO | UART_FCR_R_TRIG_10,
.flags = UART_CAP_FIFO,
},
};
#if defined (CONFIG_SERIAL_8250_AU1X00)
-@@ -2455,7 +2462,11 @@ static void serial8250_console_putchar(s
+@@ -2455,7 +2462,11 @@
{
struct uart_8250_port *up = (struct uart_8250_port *)port;
serial_out(up, UART_TX, ch);
}
-Index: linux-2.6.25.4/include/linux/serial_core.h
-===================================================================
---- linux-2.6.25.4.orig/include/linux/serial_core.h
-+++ linux-2.6.25.4/include/linux/serial_core.h
+--- a/include/linux/serial_core.h
++++ b/include/linux/serial_core.h
@@ -40,7 +40,8 @@
#define PORT_NS16550A 14
#define PORT_XSCALE 15
-Index: linux-2.6.25.4/drivers/net/cpmac.c
-===================================================================
---- linux-2.6.25.4.orig/drivers/net/cpmac.c
-+++ linux-2.6.25.4/drivers/net/cpmac.c
-@@ -936,7 +936,8 @@ static void cpmac_adjust_link(struct net
+--- a/drivers/net/cpmac.c
++++ b/drivers/net/cpmac.c
+@@ -947,7 +947,8 @@
int new_state = 0;
spin_lock(&priv->lock);
- if (priv->phy->link) {
-+ if (1 /* priv->phy->link */ ) {
++ if (1 /* priv->phy->link */) {
+ netif_carrier_on(dev);
netif_start_queue(dev);
if (priv->phy->duplex != priv->oldduplex) {
new_state = 1;
-@@ -948,11 +949,11 @@ static void cpmac_adjust_link(struct net
+@@ -959,11 +960,11 @@
priv->oldspeed = priv->phy->speed;
}