projects
/
openwrt
/
staging
/
hauke.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
e29d26e
)
move i2c module to target modules.mk
author
Florian Fainelli
<florian@openwrt.org>
Sun, 29 Jul 2012 13:20:51 +0000
(13:20 +0000)
committer
Florian Fainelli
<florian@openwrt.org>
Sun, 29 Jul 2012 13:20:51 +0000
(13:20 +0000)
SVN-Revision: 32910
target/linux/at91/modules.mk
patch
|
blob
|
history
diff --git
a/target/linux/at91/modules.mk
b/target/linux/at91/modules.mk
index 9c8ef3d5a8e83977147e3970301b2cc601cfe1ca..3f20bb8a44e3eb97cf9d68b5457bd8aa8f6c4a36 100644
(file)
--- a/
target/linux/at91/modules.mk
+++ b/
target/linux/at91/modules.mk
@@
-49,3
+49,20
@@
define KernelPackage/at91-adc/description
endef
$(eval $(call KernelPackage,at91-adc))
+
+
+I2C_AT91_MODULES:=\
+ CONFIG_I2C_AT91:drivers/i2c/busses/i2c-at91
+
+define KernelPackage/at91-i2c
+ $(call i2c_defaults,$(I2C_AT91_MODULES),55)
+ TITLE:=I2C (TWI) master driver for Atmel AT91
+ DEPENDS:=@TARGET_at91 +kmod-i2c-core
+endef
+
+define KernelPackage/at91-i2c/description
+ Kernel module to use the I2C (TWI) master driver for Atmel AT91
+endef
+
+$(eval $(call KernelPackage,at91-i2c))
+