ath10k-ct: bump to version 6.7
authorChristian Marangi <ansuelsmth@gmail.com>
Mon, 17 Jun 2024 17:00:05 +0000 (19:00 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Tue, 18 Jun 2024 12:09:42 +0000 (14:09 +0200)
Bump ath10k-ct to version 6.7.

Drop patch 100 that got merged upstream.

Link: https://github.com/openwrt/openwrt/pull/15735
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
package/kernel/ath10k-ct/Makefile
package/kernel/ath10k-ct/patches/100-ath10k-ct-port-compilation-warning-for-debug-level-t.patch [deleted file]
package/kernel/ath10k-ct/patches/130-ath10k-read-qcom-coexist-support-as-a-u32.patch
package/kernel/ath10k-ct/patches/201-wifi-ath10k-add-LED-and-GPIO-controlling-support-for.patch
package/kernel/ath10k-ct/patches/202-ath10k-use-tpt-trigger-by-default.patch
package/kernel/ath10k-ct/patches/300-fix-fortify-checking-error.patch
package/kernel/ath10k-ct/patches/960-0010-ath10k-limit-htt-rx-ring-size.patch
package/kernel/ath10k-ct/patches/960-0011-ath10k-limit-pci-buffer-size.patch
package/kernel/ath10k-ct/patches/988-ath10k-always-use-mac80211-loss-detection.patch

index 1d9856d8cd2dc3f60bd91aa1210e1927c23f274f..53d9eec1eac23cb585febde72ce6ce09b67c5757 100644 (file)
@@ -8,14 +8,14 @@ PKG_LICENSE_FILES:=
 
 PKG_SOURCE_URL:=https://github.com/greearb/ath10k-ct.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2023-06-05
-PKG_SOURCE_VERSION:=fadd0768cbd22248a60efbb219ccefc9d86cd78c
-PKG_MIRROR_HASH:=caaa373ae2cc6e443e8a31e43e5e2caca4f4ba2b9614efd3e5c9df401056d307
+PKG_SOURCE_DATE:=2024-03-03
+PKG_SOURCE_VERSION:=eb3f488a200fafc46140fd51b5e21f737ee50f24
+PKG_MIRROR_HASH:=368ed648dc7239dbcac3c6ba09be92c4b706118052d35e058cf5d1dae2917039
 
-# Build the 6.4 ath10k-ct driver version.
+# Build the 6.7 ath10k-ct driver version.
 # Probably this should match as closely as
 # possible to whatever mac80211 backports version is being used.
-CT_KVER="-6.4"
+CT_KVER="-6.7"
 
 PKG_MAINTAINER:=Ben Greear <greearb@candelatech.com>
 PKG_BUILD_PARALLEL:=1
diff --git a/package/kernel/ath10k-ct/patches/100-ath10k-ct-port-compilation-warning-for-debug-level-t.patch b/package/kernel/ath10k-ct/patches/100-ath10k-ct-port-compilation-warning-for-debug-level-t.patch
deleted file mode 100644 (file)
index f4522c8..0000000
+++ /dev/null
@@ -1,111 +0,0 @@
-From a227621b46df8a7a5c276131b245f40eac7513fb Mon Sep 17 00:00:00 2001
-From: Christian Marangi <ansuelsmth@gmail.com>
-Date: Fri, 3 Nov 2023 04:03:08 +0100
-Subject: [PATCH] ath10k-ct: port compilation warning for debug level to kernel
- 6.4
-
-Port compilation warning for debug level previously fixed in other
-kernel to kernel version 6.4.
-
-Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
----
- ath10k-6.4/debug.c | 85 ++++++++++++++++++++++++++--------------------
- 1 file changed, 48 insertions(+), 37 deletions(-)
-
---- a/ath10k-6.4/debug.c
-+++ b/ath10k-6.4/debug.c
-@@ -1345,47 +1345,58 @@ static const struct file_operations fops
-       .llseek = default_llseek,
- };
-+static const char debug_level_buf[] =
-+      "To change debug level, set value adding up desired flags:\n"
-+      "PCI:                0x1\n"
-+      "WMI:                0x2\n"
-+      "HTC:                0x4\n"
-+      "HTT:                0x8\n"
-+      "MAC:               0x10\n"
-+      "BOOT:              0x20\n"
-+      "PCI-DUMP:          0x40\n"
-+      "HTT-DUMP:          0x80\n"
-+      "MGMT:             0x100\n"
-+      "DATA:             0x200\n"
-+      "BMI:              0x400\n"
-+      "REGULATORY:       0x800\n"
-+      "TESTMODE:        0x1000\n"
-+      "WMI-PRINT:       0x2000\n"
-+      "PCI-PS:          0x4000\n"
-+      "AHB:             0x8000\n"
-+      "SDIO:           0x10000\n"
-+      "SDIO_DUMP:      0x20000\n"
-+      "USB:            0x40000\n"
-+      "USB_BULK:       0x80000\n"
-+      "SNOC:          0x100000\n"
-+      "QMI:           0x200000\n"
-+      "BEACONS:      0x8000000\n"
-+      "NO-FW-DBGLOG:0x10000000\n"
-+      "MAC2:        0x20000000\n"
-+      "INFO-AS-DBG: 0x40000000\n"
-+      "FW:          0x80000000\n"
-+      "ALL:         0xEFFFFFFF\n";
-+
-+#define READ_DEBUG_LEVEL_SIZE sizeof(debug_level_buf) + 60
-+
- static ssize_t ath10k_read_debug_level(struct file *file,
-                                      char __user *user_buf,
-                                      size_t count, loff_t *ppos)
- {
--      int sz;
--      const char buf[] =
--              "To change debug level, set value adding up desired flags:\n"
--              "PCI:                0x1\n"
--              "WMI:                0x2\n"
--              "HTC:                0x4\n"
--              "HTT:                0x8\n"
--              "MAC:               0x10\n"
--              "BOOT:              0x20\n"
--              "PCI-DUMP:          0x40\n"
--              "HTT-DUMP:          0x80\n"
--              "MGMT:             0x100\n"
--              "DATA:             0x200\n"
--              "BMI:              0x400\n"
--              "REGULATORY:       0x800\n"
--              "TESTMODE:        0x1000\n"
--              "WMI-PRINT:       0x2000\n"
--              "PCI-PS:          0x4000\n"
--              "AHB:             0x8000\n"
--              "SDIO:           0x10000\n"
--              "SDIO_DUMP:      0x20000\n"
--              "USB:            0x40000\n"
--              "USB_BULK:       0x80000\n"
--              "SNOC:          0x100000\n"
--              "QMI:           0x200000\n"
--              "BEACONS:      0x8000000\n"
--              "NO-FW-DBGLOG:0x10000000\n"
--              "MAC2:        0x20000000\n"
--              "INFO-AS-DBG: 0x40000000\n"
--              "FW:          0x80000000\n"
--              "ALL:         0xEFFFFFFF\n";
--      char wbuf[sizeof(buf) + 60];
--      sz = snprintf(wbuf, sizeof(wbuf), "Current debug level: 0x%x\n\n%s",
--                    ath10k_debug_mask, buf);
--      wbuf[sizeof(wbuf) - 1] = 0;
-+      int sz, ret;
-+      char *wbuf;
-+
-+      wbuf = kcalloc(READ_DEBUG_LEVEL_SIZE, sizeof(char), GFP_KERNEL);
-+      if (!wbuf)
-+              return -ENOMEM;
-+
-+      sz = snprintf(wbuf, READ_DEBUG_LEVEL_SIZE,
-+                    "Current debug level: 0x%x\n\n%s",
-+                    ath10k_debug_mask, debug_level_buf);
-+
-+      ret = simple_read_from_buffer(user_buf, count, ppos, wbuf, sz);
-+      kfree(wbuf);
--      return simple_read_from_buffer(user_buf, count, ppos, wbuf, sz);
-+      return ret;
- }
- /* Set logging level.
index 891973f38dbe2be278bc9a628ef871d8d1c32430..f5fc3b2ec8030d3d0ba1c0986fddce8df77e92a2 100644 (file)
@@ -39,8 +39,8 @@ that the feature is properly initialized:
 
 Signed-off-by: Vincent Tremblay <vincent@vtremblay.dev>
 
---- a/ath10k-6.4/core.c
-+++ b/ath10k-6.4/core.c
+--- a/ath10k-6.7/core.c
++++ b/ath10k-6.7/core.c
 @@ -2869,14 +2869,14 @@ done:
  static void ath10k_core_fetch_btcoex_dt(struct ath10k *ar)
  {
index 4f26806b5bc35736ec60917af54b1d1de3c5d353..701fbb9e6f52ea8185700815ee1b3bcce9271f8f 100644 (file)
@@ -20,24 +20,24 @@ Tested-by: Stefan Lippers-Hollmann <s.l-h@gmx.de>
 Signed-off-by: Kalle Valo <quic_kvalo@quicinc.com>
 Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
 ---
- ath10k-6.4/Kconfig   |  6 ++
- ath10k-6.4/Makefile  |  1 +
- ath10k-6.4/core.c    | 32 ++++++++
- ath10k-6.4/core.h    |  8 ++
- ath10k-6.4/hw.h      |  1 +
- ath10k-6.4/leds.c    | 90 +++++++++++++++++++++++
- ath10k-6.4/leds.h    | 34 +++++++++
- ath10k-6.4/mac.c     |  1 +
- ath10k-6.4/wmi-ops.h | 32 ++++++++
- ath10k-6.4/wmi-tlv.c |  2 +
- ath10k-6.4/wmi.c     | 54 ++++++++++++++
- ath10k-6.4/wmi.h     | 35 +++++++++
+ ath10k-6.7/Kconfig   |  6 ++
+ ath10k-6.7/Makefile  |  1 +
+ ath10k-6.7/core.c    | 32 ++++++++
+ ath10k-6.7/core.h    |  8 ++
+ ath10k-6.7/hw.h      |  1 +
+ ath10k-6.7/leds.c    | 90 +++++++++++++++++++++++
+ ath10k-6.7/leds.h    | 34 +++++++++
+ ath10k-6.7/mac.c     |  1 +
+ ath10k-6.7/wmi-ops.h | 32 ++++++++
+ ath10k-6.7/wmi-tlv.c |  2 +
+ ath10k-6.7/wmi.c     | 54 ++++++++++++++
+ ath10k-6.7/wmi.h     | 35 +++++++++
  12 files changed, 296 insertions(+)
- create mode 100644 ath10k-6.4/leds.c
- create mode 100644 ath10k-6.4/leds.h
+ create mode 100644 ath10k-6.7/leds.c
+ create mode 100644 ath10k-6.7/leds.h
 
---- a/ath10k-6.4/Kconfig
-+++ b/ath10k-6.4/Kconfig
+--- a/ath10k-6.7/Kconfig
++++ b/ath10k-6.7/Kconfig
 @@ -67,6 +67,12 @@ config ATH10K_DEBUGFS
  
          If unsure, say Y to make it easier to debug problems.
@@ -51,8 +51,8 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
  config ATH10K_SPECTRAL
        bool "Atheros ath10k spectral scan support"
        depends on ATH10K_DEBUGFS
---- a/ath10k-6.4/Makefile
-+++ b/ath10k-6.4/Makefile
+--- a/ath10k-6.7/Makefile
++++ b/ath10k-6.7/Makefile
 @@ -20,6 +20,7 @@ ath10k_core-$(CONFIG_ATH10K_SPECTRAL) +=
  ath10k_core-$(CONFIG_NL80211_TESTMODE) += testmode.o
  ath10k_core-$(CONFIG_ATH10K_TRACING) += trace.o
@@ -61,8 +61,8 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
  ath10k_core-$(CONFIG_MAC80211_DEBUGFS) += debugfs_sta.o
  ath10k_core-$(CONFIG_PM) += wow.o
  ath10k_core-$(CONFIG_ATH10K_CE) += ce.o
---- a/ath10k-6.4/core.c
-+++ b/ath10k-6.4/core.c
+--- a/ath10k-6.7/core.c
++++ b/ath10k-6.7/core.c
 @@ -28,6 +28,7 @@
  #include "testmode.h"
  #include "wmi-ops.h"
@@ -199,7 +199,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
                .continuous_frag_desc = true,
                .tx_chain_mask = 0x7,
                .rx_chain_mask = 0x7,
-@@ -4080,6 +4097,10 @@ int ath10k_core_start(struct ath10k *ar,
+@@ -4071,6 +4088,10 @@ int ath10k_core_start(struct ath10k *ar,
                        ath10k_wmi_check_apply_board_power_ctl_table(ar);
        }
  
@@ -210,7 +210,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
        return 0;
  
  err_hif_stop:
-@@ -4341,9 +4362,18 @@ static void ath10k_core_register_work(st
+@@ -4332,9 +4353,18 @@ static void ath10k_core_register_work(st
                goto err_spectral_destroy;
        }
  
@@ -229,7 +229,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
  err_spectral_destroy:
        ath10k_spectral_destroy(ar);
  err_debug_destroy:
-@@ -4403,6 +4433,8 @@ void ath10k_core_unregister(struct ath10
+@@ -4394,6 +4424,8 @@ void ath10k_core_unregister(struct ath10
        if (!test_bit(ATH10K_FLAG_CORE_REGISTERED, &ar->dev_flags))
                return;
  
@@ -238,8 +238,8 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
        ath10k_thermal_unregister(ar);
        /* Stop spectral before unregistering from mac80211 to remove the
         * relayfs debugfs file cleanly. Otherwise the parent debugfs tree
---- a/ath10k-6.4/core.h
-+++ b/ath10k-6.4/core.h
+--- a/ath10k-6.7/core.h
++++ b/ath10k-6.7/core.h
 @@ -14,6 +14,7 @@
  #include <linux/pci.h>
  #include <linux/uuid.h>
@@ -248,7 +248,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
  
  #include "htt.h"
  #include "htc.h"
-@@ -1586,6 +1587,13 @@ struct ath10k {
+@@ -1589,6 +1590,13 @@ struct ath10k {
        } testmode;
  
        struct {
@@ -262,8 +262,8 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
                /* protected by data_lock */
                u32 rx_crc_err_drop;
                u32 fw_crash_counter;
---- a/ath10k-6.4/hw.h
-+++ b/ath10k-6.4/hw.h
+--- a/ath10k-6.7/hw.h
++++ b/ath10k-6.7/hw.h
 @@ -523,6 +523,7 @@ struct ath10k_hw_params {
        const char *name;
        u32 patch_load_addr;
@@ -273,7 +273,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
  
        /* Type of hw cycle counter wraparound logic, for more info
 --- /dev/null
-+++ b/ath10k-6.4/leds.c
++++ b/ath10k-6.7/leds.c
 @@ -0,0 +1,90 @@
 +// SPDX-License-Identifier: ISC
 +/*
@@ -366,7 +366,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
 +}
 +
 --- /dev/null
-+++ b/ath10k-6.4/leds.h
++++ b/ath10k-6.7/leds.h
 @@ -0,0 +1,34 @@
 +/* SPDX-License-Identifier: ISC */
 +/*
@@ -402,8 +402,8 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
 +
 +#endif
 +#endif /* _LEDS_H_ */
---- a/ath10k-6.4/mac.c
-+++ b/ath10k-6.4/mac.c
+--- a/ath10k-6.7/mac.c
++++ b/ath10k-6.7/mac.c
 @@ -25,6 +25,7 @@
  #include "wmi-tlv.h"
  #include "wmi-ops.h"
@@ -412,8 +412,8 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
  
  /*********/
  /* Rates */
---- a/ath10k-6.4/wmi-ops.h
-+++ b/ath10k-6.4/wmi-ops.h
+--- a/ath10k-6.7/wmi-ops.h
++++ b/ath10k-6.7/wmi-ops.h
 @@ -228,7 +228,10 @@ struct wmi_ops {
                         const struct wmi_bb_timing_cfg_arg *arg);
        struct sk_buff *(*gen_per_peer_per_tid_cfg)(struct ath10k *ar,
@@ -461,8 +461,8 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
  static inline int
  ath10k_wmi_dbglog_cfg(struct ath10k *ar, u64 module_enable, u32 log_level)
  {
---- a/ath10k-6.4/wmi-tlv.c
-+++ b/ath10k-6.4/wmi-tlv.c
+--- a/ath10k-6.7/wmi-tlv.c
++++ b/ath10k-6.7/wmi-tlv.c
 @@ -4601,6 +4601,8 @@ static const struct wmi_ops wmi_tlv_ops
        .gen_echo = ath10k_wmi_tlv_op_gen_echo,
        .gen_vdev_spectral_conf = ath10k_wmi_tlv_op_gen_vdev_spectral_conf,
@@ -472,9 +472,9 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
  };
  
  static const struct wmi_peer_flags_map wmi_tlv_peer_flags_map = {
---- a/ath10k-6.4/wmi.c
-+++ b/ath10k-6.4/wmi.c
-@@ -8438,6 +8438,49 @@ ath10k_wmi_op_gen_peer_set_param(struct
+--- a/ath10k-6.7/wmi.c
++++ b/ath10k-6.7/wmi.c
+@@ -8446,6 +8446,49 @@ ath10k_wmi_op_gen_peer_set_param(struct
        return skb;
  }
  
@@ -524,7 +524,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
  static struct sk_buff *
  ath10k_wmi_op_gen_set_psmode(struct ath10k *ar, u32 vdev_id,
                             enum wmi_sta_ps_mode psmode)
-@@ -10269,6 +10312,9 @@ static const struct wmi_ops wmi_ops = {
+@@ -10255,6 +10298,9 @@ static const struct wmi_ops wmi_ops = {
        .fw_stats_fill = ath10k_wmi_main_op_fw_stats_fill,
        .get_vdev_subtype = ath10k_wmi_op_get_vdev_subtype,
        .gen_echo = ath10k_wmi_op_gen_echo,
@@ -534,7 +534,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
        /* .gen_bcn_tmpl not implemented */
        /* .gen_prb_tmpl not implemented */
        /* .gen_p2p_go_bcn_ie not implemented */
-@@ -10339,6 +10385,8 @@ static const struct wmi_ops wmi_10_1_ops
+@@ -10325,6 +10371,8 @@ static const struct wmi_ops wmi_10_1_ops
        .fw_stats_fill = ath10k_wmi_10x_op_fw_stats_fill,
        .get_vdev_subtype = ath10k_wmi_op_get_vdev_subtype,
        .gen_echo = ath10k_wmi_op_gen_echo,
@@ -543,7 +543,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
        /* .gen_bcn_tmpl not implemented */
        /* .gen_prb_tmpl not implemented */
        /* .gen_p2p_go_bcn_ie not implemented */
-@@ -10418,6 +10466,8 @@ static const struct wmi_ops wmi_10_2_ops
+@@ -10404,6 +10452,8 @@ static const struct wmi_ops wmi_10_2_ops
        .gen_delba_send = ath10k_wmi_op_gen_delba_send,
        .fw_stats_fill = ath10k_wmi_10x_op_fw_stats_fill,
        .get_vdev_subtype = ath10k_wmi_op_get_vdev_subtype,
@@ -552,7 +552,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
        /* .gen_pdev_enable_adaptive_cca not implemented */
  };
  
-@@ -10489,6 +10539,8 @@ static const struct wmi_ops wmi_10_2_4_o
+@@ -10475,6 +10525,8 @@ static const struct wmi_ops wmi_10_2_4_o
                ath10k_wmi_op_gen_pdev_enable_adaptive_cca,
        .get_vdev_subtype = ath10k_wmi_10_2_4_op_get_vdev_subtype,
        .gen_bb_timing = ath10k_wmi_10_2_4_op_gen_bb_timing,
@@ -561,7 +561,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
        /* .gen_bcn_tmpl not implemented */
        /* .gen_prb_tmpl not implemented */
        /* .gen_p2p_go_bcn_ie not implemented */
-@@ -10571,6 +10623,8 @@ static const struct wmi_ops wmi_10_4_ops
+@@ -10557,6 +10609,8 @@ static const struct wmi_ops wmi_10_4_ops
        .gen_pdev_bss_chan_info_req = ath10k_wmi_10_2_op_gen_pdev_bss_chan_info,
        .gen_echo = ath10k_wmi_op_gen_echo,
        .gen_pdev_get_tpc_config = ath10k_wmi_10_2_4_op_gen_pdev_get_tpc_config,
@@ -570,8 +570,8 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
  };
  
  int ath10k_wmi_attach(struct ath10k *ar)
---- a/ath10k-6.4/wmi.h
-+++ b/ath10k-6.4/wmi.h
+--- a/ath10k-6.7/wmi.h
++++ b/ath10k-6.7/wmi.h
 @@ -3133,6 +3133,41 @@ enum wmi_10_4_feature_mask {
  
  };
index c5a6d19cac4ce0f5ad223fa33f478eb9c8fca424..39b7f645d757ffe1f282014d3ccc66dcecbb69aa 100644 (file)
@@ -9,14 +9,14 @@ traffic.
 
 Signed-off-by: Mathias Kresin <dev@kresin.me>
 ---
- ath10k-6.4/core.h | 4 ++++
- ath10k-6.4/leds.c | 4 +---
- ath10k-6.4/mac.c  | 2 +-
+ ath10k-6.7/core.h | 4 ++++
+ ath10k-6.7/leds.c | 4 +---
+ ath10k-6.7/mac.c  | 2 +-
  3 files changed, 6 insertions(+), 4 deletions(-)
 
---- a/ath10k-6.4/core.h
-+++ b/ath10k-6.4/core.h
-@@ -1701,6 +1701,10 @@ struct ath10k {
+--- a/ath10k-6.7/core.h
++++ b/ath10k-6.7/core.h
+@@ -1704,6 +1704,10 @@ struct ath10k {
        u8 csi_data[4096];
        u16 csi_data_len;
  
@@ -27,8 +27,8 @@ Signed-off-by: Mathias Kresin <dev@kresin.me>
        /* must be last */
        u8 drv_priv[] __aligned(sizeof(void *));
  };
---- a/ath10k-6.4/leds.c
-+++ b/ath10k-6.4/leds.c
+--- a/ath10k-6.7/leds.c
++++ b/ath10k-6.7/leds.c
 @@ -70,7 +70,7 @@ int ath10k_leds_register(struct ath10k *
  
        ar->leds.cdev.name = ar->leds.label;
@@ -38,9 +38,9 @@ Signed-off-by: Mathias Kresin <dev@kresin.me>
  
        ret = led_classdev_register(wiphy_dev(ar->hw->wiphy), &ar->leds.cdev);
        if (ret)
---- a/ath10k-6.4/mac.c
-+++ b/ath10k-6.4/mac.c
-@@ -11616,7 +11616,7 @@ int ath10k_mac_register(struct ath10k *a
+--- a/ath10k-6.7/mac.c
++++ b/ath10k-6.7/mac.c
+@@ -11622,7 +11622,7 @@ int ath10k_mac_register(struct ath10k *a
        ar->hw->weight_multiplier = ATH10K_AIRTIME_WEIGHT_MULTIPLIER;
  
  #ifdef CPTCFG_MAC80211_LEDS
index 6966a5a4877af6470f7938f1b56f1c667b545152..1797b16dcf20441d9ba8f73bbd4a1ee1244d07c5 100644 (file)
@@ -1,5 +1,5 @@
---- a/ath10k-6.4/wmi.h
-+++ b/ath10k-6.4/wmi.h
+--- a/ath10k-6.7/wmi.h
++++ b/ath10k-6.7/wmi.h
 @@ -6341,7 +6341,7 @@ struct qca9880_set_ctl_table_cmd {
        __le32 ctl_len; /* in bytes.  This may be ignored in firmware,
                         * make sure ctl_info data is sizeof(qca9880_power_ctl) */
index b0e6ef76fa49d89421501d7bae5750c5038fbe6b..5fb70ab5c712e29734965038855a7513e4664967 100644 (file)
@@ -1,5 +1,5 @@
---- a/ath10k-6.4/htt.h
-+++ b/ath10k-6.4/htt.h
+--- a/ath10k-6.7/htt.h
++++ b/ath10k-6.7/htt.h
 @@ -237,7 +237,11 @@ enum htt_rx_ring_flags {
  };
  
index 82109995d994e5d9611260277b96965a7960d44f..eceb66c3bb8aace6d952a7893d1dd0e84d6d7286 100644 (file)
@@ -1,5 +1,5 @@
---- a/ath10k-6.4/pci.c
-+++ b/ath10k-6.4/pci.c
+--- a/ath10k-6.7/pci.c
++++ b/ath10k-6.7/pci.c
 @@ -131,7 +131,11 @@ static const struct ce_attr pci_host_ce_
                .flags = CE_ATTR_FLAGS,
                .src_nentries = 0,
index 8aef577debc3fac06b4367ac29dd23258b5546a7..165f1803883e34a6d60877a0109b0bd2416c5bbb 100644 (file)
@@ -13,12 +13,12 @@ own loss detection mechanism.
 
 Signed-off-by: David Bauer <mail@david-bauer.net>
 ---
- ath10k-6.4/mac.c | 1 -
+ ath10k-6.7/mac.c | 1 -
  1 file changed, 1 deletion(-)
 
---- a/ath10k-6.4/mac.c
-+++ b/ath10k-6.4/mac.c
-@@ -11305,7 +11305,6 @@ int ath10k_mac_register(struct ath10k *a
+--- a/ath10k-6.7/mac.c
++++ b/ath10k-6.7/mac.c
+@@ -11311,7 +11311,6 @@ int ath10k_mac_register(struct ath10k *a
        ieee80211_hw_set(ar->hw, CHANCTX_STA_CSA);
        ieee80211_hw_set(ar->hw, QUEUE_CONTROL);
        ieee80211_hw_set(ar->hw, SUPPORTS_TX_FRAG);