projects
/
openwrt
/
staging
/
lynxis.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
c5b10c8
)
image/cpio.gz: ensure inodes are allocated in a reproducible way
author
Alexander Couzens
<lynxis@fe80.eu>
Fri, 20 Sep 2019 14:55:27 +0000
(16:55 +0200)
committer
Alexander Couzens
<lynxis@fe80.eu>
Fri, 20 Sep 2019 14:55:50 +0000
(16:55 +0200)
Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
include/image.mk
patch
|
blob
|
history
diff --git
a/include/image.mk
b/include/image.mk
index 5d54bc7947e692dacd7b4e4e2e845b0e824bfc30..c964bd5aacf31668dbcde2f5d61609977d03187e 100644
(file)
--- a/
include/image.mk
+++ b/
include/image.mk
@@
-327,7
+327,7
@@
endif
ifdef CONFIG_TARGET_ROOTFS_CPIOGZ
define Image/Build/cpiogz
- ( cd $(TARGET_DIR); find . | cpio -o -H newc -R root:root | gzip -9n >$(BIN_DIR)/$(IMG_ROOTFS).cpio.gz )
+ ( cd $(TARGET_DIR); find . | cpio -
-reproducible -
o -H newc -R root:root | gzip -9n >$(BIN_DIR)/$(IMG_ROOTFS).cpio.gz )
endef
endif