packages/xinetd: use new service functions
authorNicolas Thill <nico@openwrt.org>
Wed, 9 Nov 2011 23:29:31 +0000 (23:29 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 9 Nov 2011 23:29:31 +0000 (23:29 +0000)
SVN-Revision: 28908

net/xinetd/Makefile
net/xinetd/files/xinetd.init

index 176cfa58791d9ceaadf5ac83f68f591bb3a9e51b..52b1deab27eb30dccc10e7647ded32208b49ff30 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xinetd
 PKG_VERSION:=2.3.14
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.xinetd.org/
index c11994bd475760c824daaf85717c497bb15f6c22..1437f587c52e3505a8c3af8b0fee98a0d9cb544e 100644 (file)
@@ -1,18 +1,15 @@
 #!/bin/sh /etc/rc.common
 # Copyright (C) 2006-2011 OpenWrt.org
+
 START=50
 
-DEFAULT=/etc/default/xinetd
-RUN_D=/var/run
-PID_F=$RUN_D/xinetd.pid
+SERVICE_USE_PID=1
 
 start() {
-       [ -f $DEFAULT ] && . $DEFAULT
-       [ -d $RUN_D ] || mkdir -p $RUN_D
-       xinetd -pidfile $PID_F $OPTIONS
+       service_start /usr/sbin/xinetd -pidfile /var/run/xinetd.pid
 }
 
 stop() {
-       [ -f $PID_F ] && kill $(cat $PID_F)
+       service_stop /usr/sbin/xinetd
 }