projects
/
openwrt
/
staging
/
stintel.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
3f506bd
)
Remove existing old link before creating a new one
author
Stefan Weil
<sw@weilnetz.de>
Mon, 3 Aug 2009 08:54:04 +0000
(10:54 +0200)
committer
Felix Fietkau
<nbd@nbd.name>
Mon, 25 Jul 2016 08:39:27 +0000
(10:39 +0200)
This is needed after a kernel update, otherwise the
new link is written as linux/linux-$(LINUX_VERSION).
Signed-off-by: Stefan Weil <sw@weilnetz.de>
toolchain/kernel-headers/Makefile
patch
|
blob
|
history
diff --git
a/toolchain/kernel-headers/Makefile
b/toolchain/kernel-headers/Makefile
index 68c83a065ec32ae13dca9811f3b8b1a08e9c8e40..fa7d349baadc7077543922b19c95abdbfa02b541 100644
(file)
--- a/
toolchain/kernel-headers/Makefile
+++ b/
toolchain/kernel-headers/Makefile
@@
-72,7
+72,8
@@
endef
define Host/Prepare
$(call Kernel/Prepare/Default)
- ln -sf linux-$(LINUX_VERSION) $(BUILD_DIR_TOOLCHAIN)/linux
+ rm -f $(BUILD_DIR_TOOLCHAIN)/linux
+ ln -s linux-$(LINUX_VERSION) $(BUILD_DIR_TOOLCHAIN)/linux
$(SED) 's/@expr length/@-expr length/' $(HOST_BUILD_DIR)/Makefile
endef