uboot-imx: fix wrong make flags overriding
authorPetr Štetiar <ynezz@true.cz>
Sat, 28 May 2022 12:18:06 +0000 (14:18 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 7 Jun 2022 20:28:59 +0000 (22:28 +0200)
Buidbots are currently choking on the following compile error:

 In file included from tools/aisimage.c:9:
 include/image.h:1133:12: fatal error: openssl/evp.h: No such file or directory
  #  include <openssl/evp.h>
             ^~~~~~~~~~~~~~~
 compilation terminated.

This is caused by a complete overriding of make flags which are provided
correctly in `UBOOT_MAKE_FLAGS` variable, but currently overriden
instead of extended. This then leads to the usage of build host include
dirs, which are not available.

Fix it by extending `UBOOT_MAKE_FLAGS` variable in all device recipes.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
(cherry picked from commit 481339a0426698adaa0254b479807efde0428de9)

package/boot/uboot-imx/Makefile

index 2faa48bd7367eb5f112ee454169446252c8c1437..cc43269782281a2fa2d01b327455974ef5b09f5c 100644 (file)
@@ -23,7 +23,7 @@ endef
 define U-Boot/apalis_imx6
   NAME:=Toradex Apalis
   UBOOT_IMAGE:=SPL u-boot.img u-boot-with-spl.imx
-  UBOOT_MAKE_FLAGS:=SPL u-boot.img u-boot-with-spl.imx
+  UBOOT_MAKE_FLAGS+=SPL u-boot.img u-boot-with-spl.imx
   BUILD_SUBTARGET:=cortexa9
   BUILD_DEVICES:=toradex_apalis
 endef
@@ -31,7 +31,7 @@ endef
 define U-Boot/mx6cuboxi
   NAME:=SolidRun Cubox-i boards
   UBOOT_IMAGE:=SPL u-boot.img
-  UBOOT_MAKE_FLAGS:=SPL u-boot.img
+  UBOOT_MAKE_FLAGS+=SPL u-boot.img
   BUILD_SUBTARGET:=cortexa9
   BUILD_DEVICES:=solidrun_cubox-i
 endef