kernel: re-add missing symbols
authorKoen Vandeputte <koen.vandeputte@citymesh.com>
Tue, 11 Jun 2024 13:27:58 +0000 (15:27 +0200)
committerKoen Vandeputte <koen.vandeputte@citymesh.com>
Mon, 21 Oct 2024 07:19:01 +0000 (09:19 +0200)
a recent cleanup commit also removed our own custom symbols
added by various in-tree drivers.

re-add these symbols as the compiler will complain about
them otherwise on specific targets during kernel build:

MikroTik RB91x NAND driver support (MTD_NAND_RB91X) [N/m/y/?] (NEW) make[8]: *** [scripts/kconfig/Makefile:77: syncconfig] Error 1

Fixes: 2d00ed7caa ("kernel: trim outdated kernel config symbols")
Signed-off-by: Koen Vandeputte <koen.vandeputte@citymesh.com>
target/linux/generic/config-6.6

index 5403dbab9a3868c1fc702571b7522dffdd755d8b..a33224f6ea1bd0240a167b038163f8f030a02e6a 100644 (file)
@@ -3726,6 +3726,10 @@ CONFIG_MTD_MAP_BANK_WIDTH_4=y
 # CONFIG_MTD_NAND_ORION is not set
 # CONFIG_MTD_NAND_PASEMI is not set
 # CONFIG_MTD_NAND_PLATFORM is not set
+# CONFIG_MTD_NAND_PXA3xx is not set
+# CONFIG_MTD_NAND_RB4XX is not set
+# CONFIG_MTD_NAND_RB750 is not set
+# CONFIG_MTD_NAND_RB91X is not set
 # CONFIG_MTD_NAND_RICOH is not set
 # CONFIG_MTD_NAND_S3C2410 is not set
 # CONFIG_MTD_NAND_SHARPSL is not set