projects
/
openwrt
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
fb2b3c9
)
hostapd: enable parallel build
author
Felix Fietkau
<nbd@openwrt.org>
Sat, 15 Sep 2012 11:37:07 +0000
(11:37 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sat, 15 Sep 2012 11:37:07 +0000
(11:37 +0000)
SVN-Revision: 33419
package/hostapd/Makefile
patch
|
blob
|
history
diff --git
a/package/hostapd/Makefile
b/package/hostapd/Makefile
index 295efd0cc33bb7c821490ec3e851a1fef95e2e22..5e2452e437349b7b7ce920dda0fcf5aaaacc635b 100644
(file)
--- a/
package/hostapd/Makefile
+++ b/
package/hostapd/Makefile
@@
-19,6
+19,8
@@
PKG_SOURCE_VERSION:=$(PKG_REV)
PKG_SOURCE_PROTO:=git
PKG_MIRROR_MD5SUM:=2732dbca58b0aaaebdad69e13588d058
+PKG_BUILD_PARALLEL:=1
+
PKG_BUILD_DEPENDS:= \
PACKAGE_kmod-madwifi:madwifi \
@@
-232,7
+234,7
@@
endif
define Build/RunMake
CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
- $(MAKE) -C $(PKG_BUILD_DIR)/$(1) \
+ $(MAKE)
$(PKG_JOBS)
-C $(PKG_BUILD_DIR)/$(1) \
$(TARGET_CONFIGURE_OPTS) \
$(DRIVER_MAKEOPTS) \
LIBS="$(TARGET_LDFLAGS)" \