projects
/
openwrt
/
staging
/
blocktrron.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
298e11e
)
kernel: add kmod-ata-ahci-dwc
author
Antonio Flores
<antflores627@gmail.com>
Thu, 11 Apr 2024 18:43:06 +0000
(14:43 -0400)
committer
Nick Hainke
<vincent@systemli.org>
Sat, 4 May 2024 22:46:48 +0000
(
00:46
+0200)
Add kmod-ata-ahci-dwc for the rockchip target.
https://github.com/torvalds/linux/commit/
33629d35090f5ce2b1b4ce78aa39954c603536d5
Signed-off-by: Antonio Flores <antflores627@gmail.com>
package/kernel/linux/modules/block.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/block.mk
b/package/kernel/linux/modules/block.mk
index 4f3a6e085ffb2296d3806fa7bb42a1b909a3ed4c..3dbeca9f9f282d66fb2e3ceb5eba2ca982cc2035 100644
(file)
--- a/
package/kernel/linux/modules/block.mk
+++ b/
package/kernel/linux/modules/block.mk
@@
-89,6
+89,18
@@
endef
$(eval $(call KernelPackage,ata-artop))
+define KernelPackage/ata-ahci-dwc
+ TITLE:=Synopsys DWC AHCI SATA
+ KCONFIG:= \
+ CONFIG_AHCI_DWC \
+ CONFIG_SATA_HOST=y
+ FILES:=$(LINUX_DIR)/drivers/ata/ahci_dwc.ko
+ DEPENDS:=+kmod-ata-ahci-platform
+ AUTOLOAD:=$(call AutoLoad,41,ahci_dwc,1)
+ $(call AddDepends/ata,@TARGET_rockchip)
+endef
+
+$(eval $(call KernelPackage,ata-ahci-dwc))
define KernelPackage/ata-nvidia-sata
TITLE:=Nvidia Serial ATA support