compat-wireless: enable uninstall for staging & atlxx
authorWalter Goldens <goldenstranger@yahoo.com>
Mon, 18 Oct 2010 18:05:33 +0000 (11:05 -0700)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Mon, 18 Oct 2010 18:05:33 +0000 (11:05 -0700)
- enable 'make uninstall' for staging - brcm80211, ath6kl and ethernet atlxx
- add atlxx to 'modprobe -l' list

Signed-off-by: Walter Goldens <goldenstranger@yahoo.com>
Makefile

index ca1dd21744751cf050b58c7abef9dbd9e53bb680..bca92ca52f64186ca54c740b182c24342dda8fbd 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -255,6 +255,13 @@ install-scripts:
        @$(MODPROBE) -l wl1271
        @$(MODPROBE) -l zd1211rw
        @echo
+       @echo "Currently detected ethernet subsystem modules:"
+       @echo
+       @$(MODPROBE) -l atl1
+       @$(MODPROBE) -l atl2
+       @$(MODPROBE) -l atl1e
+       @$(MODPROBE) -l atl1c
+       @echo
        @echo "Currently detected bluetooth subsystem modules:"
        @echo
        @$(MODPROBE) -l sco
@@ -284,6 +291,8 @@ uninstall:
        @rm -rf $(KLIB)/$(KMODDIR)/drivers/ssb/
        @rm -rf $(KLIB)/$(KMODDIR)/drivers/net/usb/
        @rm -rf $(KLIB)/$(KMODDIR)/drivers/net/wireless/
+       @rm -rf $(KLIB)/$(KMODDIR)/drivers/staging/
+       @rm -rf $(KLIB)/$(KMODDIR)/drivers/net/atl*
        @# Lets only remove the stuff we are sure we are providing
        @# on the misc directory.
        @rm -f $(KLIB)/$(KMODDIR)/drivers/misc/eeprom/eeprom_93cx6.ko*
@@ -362,6 +371,13 @@ uninstall:
        @$(MODPROBE) -l wl1271
        @$(MODPROBE) -l zd1211rw
        @echo
+       @echo "Your old ethernet subsystem modules are left intact:"
+       @echo
+       @$(MODPROBE) -l atl1
+       @$(MODPROBE) -l atl2
+       @$(MODPROBE) -l atl1e
+       @$(MODPROBE) -l atl1c
+       @echo
        @echo "Your old bluetooth subsystem modules were left intact:"
        @echo
        @$(MODPROBE) -l sco