projects
/
openwrt
/
staging
/
wigyori.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
8838ffd
)
another optimization
author
Felix Fietkau
<nbd@openwrt.org>
Sun, 12 Nov 2006 01:55:28 +0000
(
01:55
+0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sun, 12 Nov 2006 01:55:28 +0000
(
01:55
+0000)
SVN-Revision: 5507
Makefile
patch
|
blob
|
history
include/verbose.mk
patch
|
blob
|
history
diff --git
a/Makefile
b/Makefile
index d6b1b7d61854d1118c55e4c08fd52a94353012f1..62a03387463aed51e47d3c46ccb9d19928d799df 100644
(file)
--- a/
Makefile
+++ b/
Makefile
@@
-21,10
+21,15
@@
SHELL:=/usr/bin/env bash
export LC_ALL=C
export LANG=C
export TOPDIR=${shell pwd}
-include $(TOPDIR)/include/verbose.mk
ifeq ($(KBUILD_VERBOSE),99)
MAKE:=3>/dev/null $(MAKE)
endif
+ifneq ($(shell tty -s <&3 || echo x),x)
+ IS_TTY=1
+ export IS_TTY
+endif
+
+include $(TOPDIR)/include/verbose.mk
OPENWRTVERSION:=$(RELEASE)
ifneq ($(VERSION),)
diff --git
a/include/verbose.mk
b/include/verbose.mk
index 34568a31f821f3c8c3b470240ca82971cfcc4511..b4242f212acc512c4d66533932bf86838f374eab 100644
(file)
--- a/
include/verbose.mk
+++ b/
include/verbose.mk
@@
-18,7
+18,7
@@
ifeq ("$(origin V)", "command line")
KBUILD_VERBOSE:=$(V)
endif
-if
neq ($(shell tty -s <&3 || echo x),x
)
+if
eq ($(IS_TTY),1
)
_Y:="\\33[33m"# yellow
_N:="\\33[m"# normal
endif