uml: define "generic" subtarget
authorChristian Lamparter <chunkeey@gmail.com>
Fri, 14 Jun 2024 15:05:47 +0000 (17:05 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Mon, 17 Jun 2024 10:59:05 +0000 (12:59 +0200)
UML didn't have a subtarget defined.

While this compiled fine, the patch caused funny filenames
for the generated files to appear:
 - "openwrt-uml--vmlinux"
 - "openwrt-uml--squashfs.img"
 - "openwrt-uml--ext4.img"
 - ...

since "generic" is implied anyway, let's just set it.

Fixes: d997477775bf ("treewide: remove implicit SUBTARGET")
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/15713
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
target/linux/uml/Makefile
target/linux/uml/README.md
target/linux/uml/generic/target.mk [new file with mode: 0644]

index 307687ffda04a51988e4c0c301f521ef864e9508..cad5d0f3d321bb04aa88b386ffe32932712f1d47 100644 (file)
@@ -12,6 +12,7 @@ ARCH:=x86_64
 BOARD:=uml
 BOARDNAME:=User Mode Linux
 FEATURES:=audio ext4 rootfs-part squashfs
+SUBTARGETS:=generic
 
 KERNEL_PATCHVER:=6.1
 KERNEL_TESTING_PATCHVER:=6.6
index 9275f9891b90440512cca0279a01e339e1f287b9..ffdd2f0fe719416eef422257cc4829f37beb49e0 100644 (file)
@@ -20,7 +20,7 @@ In your bin directory you will find a Kernel and an root file system when it's
 finished. Just run it like this:-
 
 ```shell
-./openwrt-uml-vmlinux ubd0=openwrt-uml-squashfs.img
+./openwrt-uml-generic-vmlinux ubd0=openwrt-uml-generic-squashfs.img
 ```
 
 The uml will start and eventually the serial console of the uml will be at your
diff --git a/target/linux/uml/generic/target.mk b/target/linux/uml/generic/target.mk
new file mode 100644 (file)
index 0000000..f5cb1fb
--- /dev/null
@@ -0,0 +1 @@
+BOARDNAME:=Generic