[package] fix libtorrent build failure (#6981)
authorFlorian Fainelli <florian@openwrt.org>
Mon, 29 Mar 2010 11:03:30 +0000 (11:03 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 29 Mar 2010 11:03:30 +0000 (11:03 +0000)
SVN-Revision: 20578

libs/libtorrent/Makefile
libs/libtorrent/patches/130-missing_inttypes.patch [new file with mode: 0644]

index 81aa97fe066b0c9960443d40401df07a9ea8afd1..5cfe8b8b4afcd279f84497a3f1a42768c4e86106 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=libtorrent
 PKG_REV:=1130
 PKG_VERSION:=0.12.6_r$(PKG_REV)
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
diff --git a/libs/libtorrent/patches/130-missing_inttypes.patch b/libs/libtorrent/patches/130-missing_inttypes.patch
new file mode 100644 (file)
index 0000000..09ff6d8
--- /dev/null
@@ -0,0 +1,11 @@
+diff -urN libtorrent-0.12.6_r1130/rak/allocators.h libtorrent-0.12.6_r1130.new/rak/allocators.h
+--- libtorrent-0.12.6_r1130/rak/allocators.h   2009-12-26 12:16:21.000000000 +0100
++++ libtorrent-0.12.6_r1130.new/rak/allocators.h       2010-03-29 11:49:51.000000000 +0200
+@@ -43,6 +43,7 @@
+ #include <limits>
+ #include <stdlib.h>
+ #include <sys/types.h>
++#include <inttypes.h>
+ namespace rak {