projects
/
openwrt
/
staging
/
blocktrron.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
ae75153
)
toolchain/binutils: fill in missing GRAPHITE_CONFIGURE
author
Andre Heider
<a.heider@gmail.com>
Tue, 31 Jan 2023 10:07:42 +0000
(11:07 +0100)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Sun, 19 Feb 2023 18:44:39 +0000
(19:44 +0100)
This var is used further down, but it's empty.
Fix that with the very same values gcc uses.
Signed-off-by: Andre Heider <a.heider@gmail.com>
toolchain/binutils/Makefile
patch
|
blob
|
history
diff --git
a/toolchain/binutils/Makefile
b/toolchain/binutils/Makefile
index a0e112f8f6a649600dad15b7686ec78f40a61ec2..af670f56467ebf6c648917615be78fd65887030d 100644
(file)
--- a/
toolchain/binutils/Makefile
+++ b/
toolchain/binutils/Makefile
@@
-37,6
+37,12
@@
PATCH_DIR:=./patches/$(PKG_VERSION)
include $(INCLUDE_DIR)/toolchain-build.mk
+ifdef CONFIG_GCC_USE_GRAPHITE
+ GRAPHITE_CONFIGURE:= --with-isl=$(STAGING_DIR_HOST)
+else
+ GRAPHITE_CONFIGURE:= --without-isl --without-cloog
+endif
+
HOST_CONFIGURE_ARGS = \
--prefix=$(TOOLCHAIN_DIR) \
--build=$(GNU_HOST_NAME) \