compat-wireless: fix unintended merge of changes
authorLuis R. Rodriguez <lrodriguez@atheros.com>
Wed, 25 Aug 2010 23:48:28 +0000 (16:48 -0700)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Wed, 25 Aug 2010 23:49:15 +0000 (16:49 -0700)
Signed-off-by: Luis R. Rodriguez <lrodriguez@atheros.com>
config.mk
scripts/gen-compat-autoconf.sh

index 0d951d16fae94badf2b1fe9c276b3eea87b2b129..edfeca26255955b8b822a1d6821b9aff02f06907 100644 (file)
--- a/config.mk
+++ b/config.mk
@@ -25,8 +25,8 @@ KERNEL_SUBLEVEL := $(shell $(MAKE) -C $(KLIB_BUILD) kernelversion | sed -n 's/^2
 COMPAT_VERSIONS := $(shell I=$(COMPAT_LATEST_VERSION); while [ "$$I" -gt $(KERNEL_SUBLEVEL) ]; do echo $$I; I=$$(($$I - 1)); done)
 $(foreach ver,$(COMPAT_VERSIONS),$(eval CONFIG_COMPAT_KERNEL_$(ver)=y))
 
-ifdef CONFIG_COMPAT_WIRELESS_23
-$(error "ERROR: compat-wireless for selected driver requires a kernel >= 2.6.23")
+ifdef CONFIG_COMPAT_KERNEL_25
+$(error "ERROR: compat-wireless by default supports kernels >= 2.6.25, try enabling only one driver though")
 endif
 
 ifeq ($(CONFIG_CFG80211),y)
index 64dac69f69266630bdb0942156a859393e91e3fd..1e3002e8f5118e125cfa20aa59430b2c27629598 100755 (executable)
@@ -11,7 +11,7 @@
 
 # This indicates which is the oldest kernel we support
 # Update this if you are adding support for older kernels.
-OLDEST_KERNEL_SUPPORTED="2.6.23"
+OLDEST_KERNEL_SUPPORTED="2.6.25"
 COMPAT_RELEASE="compat_version"
 KERNEL_RELEASE="compat_base_tree_version"
 MULT_DEP_FILE=".compat_pivot_dep"