projects
/
openwrt
/
staging
/
blogic.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
aaa3515
)
powerpc: make syntax for FADump config options in kernel/Makefile readable
author
Hari Bathini
<hbathini@linux.ibm.com>
Wed, 9 Oct 2019 15:27:20 +0000
(20:57 +0530)
committer
Michael Ellerman
<mpe@ellerman.id.au>
Fri, 11 Oct 2019 07:49:37 +0000
(18:49 +1100)
arch/powerpc/kernel/fadump.c file needs to be compiled in if 'config
FA_DUMP' or 'config PRESERVE_FA_DUMP' is set. The current syntax
achieves that but looks a bit odd. Fix it for better readability.
Signed-off-by: Hari Bathini <hbathini@linux.ibm.com>
Signed-off-by: Michael Ellerman <mpe@ellerman.id.au>
Link:
https://lore.kernel.org/r/157063484064.11906.3586824898111397624.stgit@hbathini.in.ibm.com
arch/powerpc/kernel/Makefile
patch
|
blob
|
history
diff --git
a/arch/powerpc/kernel/Makefile
b/arch/powerpc/kernel/Makefile
index a7ca8fe623686afb43f03c7335d9f73036497781..4fdd8a3e775b7c11829db64e544e0e4ec48205d8 100644
(file)
--- a/
arch/powerpc/kernel/Makefile
+++ b/
arch/powerpc/kernel/Makefile
@@
-78,9
+78,8
@@
obj-$(CONFIG_EEH) += eeh.o eeh_pe.o eeh_dev.o eeh_cache.o \
eeh_driver.o eeh_event.o eeh_sysfs.o
obj-$(CONFIG_GENERIC_TBSYNC) += smp-tbsync.o
obj-$(CONFIG_CRASH_DUMP) += crash_dump.o
-ifneq ($(CONFIG_FA_DUMP)$(CONFIG_PRESERVE_FA_DUMP),)
-obj-y += fadump.o
-endif
+obj-$(CONFIG_FA_DUMP) += fadump.o
+obj-$(CONFIG_PRESERVE_FA_DUMP) += fadump.o
ifdef CONFIG_PPC32
obj-$(CONFIG_E500) += idle_e500.o
endif