Add vpnc-scripts package with up-to-date script
authorGabor Juhos <juhosg@openwrt.org>
Wed, 2 May 2012 19:28:06 +0000 (19:28 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 2 May 2012 19:28:06 +0000 (19:28 +0000)
This removes the hard-coded masquerading configuration from vpnc-script.
It's possible to do it in a hook now, but it also shouldn't be necessary,
because we should be invoking the hotplug scripts to plumb the interface
properly anyway.

Signed-off-by: David Woodhouse <David.Woodhouse@intel.com>
SVN-Revision: 31558

net/vpnc-scripts/Makefile [new file with mode: 0644]
net/vpnc-scripts/files/etc/vpnc/connect.d/ifstate [new file with mode: 0644]
net/vpnc/Makefile

diff --git a/net/vpnc-scripts/Makefile b/net/vpnc-scripts/Makefile
new file mode 100644 (file)
index 0000000..7481dea
--- /dev/null
@@ -0,0 +1,56 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=vpnc-scripts
+PKG_VERSION:=20120423
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=ftp://ftp.infradead.org/pub/vpnc-scripts/
+PKG_MD5SUM:=3265dc7fe57ae9b4c905961a28699c4c
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/vpnc-scripts
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+ip
+  TITLE:=VPN configuration script for vpnc and OpenConnect
+  URL:=http://www.infradead.org/openconnect/vpnc-script.html
+  SUBMENU:=VPN
+endef
+
+define Package/vpnc/vpnc-scripts
+       This package contains the vpnc-script which is used by vpnc
+       and OpenConnect to configure the tunnel interface.
+endef
+
+define Package/vpnc-scripts/conffiles
+/etc/vpnc/connect.d/
+/etc/vpnc/post-connect.d/
+/etc/vpnc/disconnect.d/
+/etc/vpnc/post-connect.d/
+/etc/vpnc/reconnect.d/
+endef
+
+define Build/Compile
+endef
+
+define Package/vpnc-scripts/install
+       $(INSTALL_DIR) $(1)/etc/vpnc
+       $(INSTALL_DIR) $(1)/etc/vpnc/connect.d
+       $(INSTALL_DIR) $(1)/etc/vpnc/post-connect.d
+       $(INSTALL_DIR) $(1)/etc/vpnc/disconnect.d
+       $(INSTALL_DIR) $(1)/etc/vpnc/post-disconnect.d
+       $(INSTALL_DIR) $(1)/etc/vpnc/reconnect.d
+       $(INSTALL_BIN) ./files/etc/vpnc/connect.d/ifstate $(1)/etc/vpnc/connect.d/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/vpnc-script $(1)/etc/vpnc/
+endef
+
+$(eval $(call BuildPackage,vpnc-scripts))
diff --git a/net/vpnc-scripts/files/etc/vpnc/connect.d/ifstate b/net/vpnc-scripts/files/etc/vpnc/connect.d/ifstate
new file mode 100644 (file)
index 0000000..8d2a157
--- /dev/null
@@ -0,0 +1,7 @@
+if [ -r /etc/openwrt_release ] && [ -n "$OPENWRT_INTERFACE" ]; then
+    uci_set_state network "$OPENWRT_INTERFACE" banner "$CISCO_BANNER"
+    uci_set_state network "$OPENWRT_INTERFACE" ifname "$TUNDEV"
+    [ -n "$INTERNAL_IP4_ADDRESS" ] && uci_set_state network "$OPENWRT_INTERFACE" ipaddr "$INTERNAL_IP4_ADDRESS"
+    [ -n "$INTERNAL_IP6_NETMASK" ] && uci_set_state network "$OPENWRT_INTERFACE" ip6addr "$INTERNAL_IP6_NETMASK"
+    env -i ACTION="ifup" INTERFACE="$OPENWRT_INTERFACE" DEVICE="$TUNDEV" PROTO=openconnect /sbin/hotplug-call "iface"
+fi
index 0b9d07e7aa7a85d73acb3efed2a4880a37c4f9ae..ad1592e15ba501655af28074ebae80461a615ac4 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vpnc
 PKG_VERSION:=0.5.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.unix-ag.uni-kl.de/~massar/vpnc/
@@ -20,7 +20,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/vpnc
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libgpg-error +libgcrypt +kmod-tun +ip
+  DEPENDS:=+libgpg-error +libgcrypt +kmod-tun +vpnc-scripts
   TITLE:=VPN client for Cisco EasyVPN
   URL:=http://www.unix-ag.uni-kl.de/~massar/vpnc/
   SUBMENU:=VPN
@@ -36,7 +36,6 @@ endef
 
 define Package/vpnc/conffiles
 /etc/vpnc/default.conf
-/etc/vpnc/vpnc-script
 endef
 
 define Build/Compile
@@ -57,7 +56,6 @@ define Package/vpnc/install
                $(1)/usr/sbin/
        install -d -m0700 $(1)/etc/vpnc
        $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/vpnc/default.conf $(1)/etc/vpnc/
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/vpnc/vpnc-script $(1)/etc/vpnc/
 endef
 
 $(eval $(call BuildPackage,vpnc))