ifeq ($(LINUX_VERSION),3.2.16)
LINUX_KERNEL_MD5SUM:=246e6bd28ea44c90ec66c7f8b56e4803
endif
-ifeq ($(LINUX_VERSION),3.3.3)
- LINUX_KERNEL_MD5SUM:=a6897310b4785b5f912c567cdc93402e
+ifeq ($(LINUX_VERSION),3.3.4)
+ LINUX_KERNEL_MD5SUM:=113baeccd2a3341ecc62ae5e73c2ed1d
endif
# disable the md5sum check for unknown kernel versions
BOARD:=adm5120
BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=3.3.3
+LINUX_VERSION:=3.3.4
SUBTARGETS:=router_le router_be rb1xx
INITRAMFS_EXTRA_FILES:=
FEATURES:=squashfs
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-LINUX_VERSION:=3.3.3
+LINUX_VERSION:=3.3.4
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += wpad-mini kmod-rt61-pci
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
SUBTARGETS:=generic nand
-LINUX_VERSION:=3.3.3
+LINUX_VERSION:=3.3.4
include $(INCLUDE_DIR)/target.mk
CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
SUBTARGETS:=9g20 9260 9263
-LINUX_VERSION:=3.3.3
+LINUX_VERSION:=3.3.4
DEVICE_TYPE=
include $(INCLUDE_DIR)/target.mk
FEATURES:=squashfs
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=3.3.3
+LINUX_VERSION:=3.3.4
include $(INCLUDE_DIR)/target.mk
BOARD:=brcm63xx
BOARDNAME:=Broadcom BCM63xx
FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=3.3.3
+LINUX_VERSION:=3.3.4
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
include $(INCLUDE_DIR)/target.mk
+MODULE_ALIAS("platform:bcm63xx_ehci");
--- a/drivers/usb/host/ehci-hcd.c
+++ b/drivers/usb/host/ehci-hcd.c
-@@ -1376,6 +1376,11 @@ MODULE_LICENSE ("GPL");
+@@ -1381,6 +1381,11 @@ MODULE_LICENSE ("GPL");
#define PLATFORM_DRIVER ehci_mv_driver
#endif
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
@@ -17,6 +17,9 @@
#include <linux/ssb/ssb.h>
- #include <linux/gpio_buttons.h>
+ #include <linux/gpio_keys.h>
#include <linux/input.h>
+#include <linux/spi/spi.h>
+#include <linux/spi/spi_gpio.h>
+ struct gpio_led leds[14];
/* Buttons */
- struct gpio_button buttons[4];
+ struct gpio_keys_button buttons[4];
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
@@ -17,6 +17,7 @@
#include <linux/ssb/ssb.h>
- #include <linux/gpio_buttons.h>
+ #include <linux/gpio_keys.h>
#include <linux/input.h>
+#include <linux/export.h>
#include <linux/spi/spi.h>
FEATURES:=squashfs broken
CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
-LINUX_VERSION:=3.3.3
+LINUX_VERSION:=3.3.4
include $(INCLUDE_DIR)/target.mk
+module_exit(ovl_exit);
--- a/fs/splice.c
+++ b/fs/splice.c
-@@ -1299,6 +1299,7 @@ long do_splice_direct(struct file *in, l
+@@ -1302,6 +1302,7 @@ long do_splice_direct(struct file *in, l
return ret;
}
+++ /dev/null
-commit 9a5d2bd99e0dfe9a31b3c160073ac445ba3d773f
-Author: David Woodhouse <dwmw2@infradead.org>
-Date: Sun Apr 8 10:01:44 2012 +0000
-
- ppp: Fix race condition with queue start/stop
-
- Commit e675f0cc9a872fd152edc0c77acfed19bf28b81e ("ppp: Don't stop and
- restart queue on every TX packet") introduced a race condition which
- could leave the net queue stopped even when the channel is no longer
- busy. By calling netif_stop_queue() from ppp_start_xmit(), based on the
- return value from ppp_xmit_process() but *after* all the locks have been
- dropped, we could potentially do so *after* the channel has actually
- finished transmitting and attempted to re-wake the queue.
-
- Fix this by moving the netif_stop_queue() into ppp_xmit_process() under
- the xmit lock. I hadn't done this previously, because it gets called
- from other places than ppp_start_xmit(). But I now think it's the better
- option. The net queue *should* be stopped if the channel becomes
- congested due to writes from pppd, anyway.
-
- Signed-off-by: David Woodhouse <David.Woodhouse@intel.com>
- Signed-off-by: David S. Miller <davem@davemloft.net>
-
-commit e675f0cc9a872fd152edc0c77acfed19bf28b81e
-Author: David Woodhouse <dwmw2@infradead.org>
-Date: Mon Mar 26 00:03:42 2012 +0000
-
- ppp: Don't stop and restart queue on every TX packet
-
- For every transmitted packet, ppp_start_xmit() will stop the netdev
- queue and then, if appropriate, restart it. This causes the TX softirq
- to run, entirely gratuitously.
-
- This is "only" a waste of CPU time in the normal case, but it's actively
- harmful when the PPP device is a TEQL slave — the wakeup will cause the
- offending device to receive the next TX packet from the TEQL queue, when
- it *should* have gone to the next slave in the list. We end up seeing
- large bursts of packets on just *one* slave device, rather than using
- the full available bandwidth over all slaves.
-
- This patch fixes the problem by *not* unconditionally stopping the queue
- in ppp_start_xmit(). It adds a return value from ppp_xmit_process()
- which indicates whether the queue should be stopped or not.
-
- It *doesn't* remove the call to netif_wake_queue() from
- ppp_xmit_process(), because other code paths (especially from
- ppp_output_wakeup()) need it there and it's messy to push it out to the
- other callers to do it based on the return value. So we leave it in
- place — it's a no-op in the case where the queue wasn't stopped, so it's
- harmless in the TX path.
-
- Signed-off-by: David Woodhouse <David.Woodhouse@intel.com>
- Signed-off-by: David S. Miller <davem@davemloft.net>
-
-
-
---- a/drivers/net/ppp/ppp_generic.c
-+++ b/drivers/net/ppp/ppp_generic.c
-@@ -968,7 +968,6 @@ ppp_start_xmit(struct sk_buff *skb, stru
- proto = npindex_to_proto[npi];
- put_unaligned_be16(proto, pp);
-
-- netif_stop_queue(dev);
- skb_queue_tail(&ppp->file.xq, skb);
- ppp_xmit_process(ppp);
- return NETDEV_TX_OK;
-@@ -1063,6 +1062,8 @@ ppp_xmit_process(struct ppp *ppp)
- code that we can accept some more. */
- if (!ppp->xmit_pending && !skb_peek(&ppp->file.xq))
- netif_wake_queue(ppp->dev);
-+ else
-+ netif_stop_queue(ppp->dev);
- }
- ppp_xmit_unlock(ppp);
- }
--- a/net/bridge/br_private.h
+++ b/net/bridge/br_private.h
-@@ -139,6 +139,7 @@ struct net_bridge_port
+@@ -135,6 +135,7 @@ struct net_bridge_port
unsigned long flags;
#define BR_HAIRPIN_MODE 0x00000001
default:
--- a/net/bridge/br_multicast.c
+++ b/net/bridge/br_multicast.c
-@@ -827,7 +827,7 @@ static void __br_multicast_send_query(st
+@@ -753,7 +753,7 @@ static void __br_multicast_send_query(st
if (port) {
__skb_push(skb, sizeof(struct ethhdr));
skb->dev = port->dev;
if (vlan_tx_tag_present(skb))
--- a/net/bridge/br_private.h
+++ b/net/bridge/br_private.h
-@@ -490,15 +490,29 @@ static inline bool br_multicast_is_route
+@@ -486,15 +486,29 @@ static inline bool br_multicast_is_route
/* br_netfilter.c */
#ifdef CONFIG_BRIDGE_NETFILTER
obj-$(CONFIG_USB_WDM) += class/
--- a/drivers/usb/core/hub.c
+++ b/drivers/usb/core/hub.c
-@@ -2938,11 +2938,11 @@ hub_port_init (struct usb_hub *hub, stru
+@@ -2935,11 +2935,11 @@ hub_port_init (struct usb_hub *hub, stru
udev->ttport = hdev->ttport;
} else if (udev->speed != USB_SPEED_HIGH
&& hdev->speed == USB_SPEED_HIGH) {
INITRAMFS_EXTRA_FILES:=
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-LINUX_VERSION:=3.3.3
+LINUX_VERSION:=3.3.4
include $(INCLUDE_DIR)/target.mk
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
FEATURES:=targz ext4
-LINUX_VERSION:=3.3.3
+LINUX_VERSION:=3.3.4
include $(INCLUDE_DIR)/target.mk
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=3.3.3
+LINUX_VERSION:=3.3.4
include $(INCLUDE_DIR)/target.mk
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
FEATURES:=squashfs
-LINUX_VERSION:=3.3.3
+LINUX_VERSION:=3.3.4
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES+=\
depends on USB
--- a/drivers/usb/host/ehci-hcd.c
+++ b/drivers/usb/host/ehci-hcd.c
-@@ -1376,6 +1376,11 @@ MODULE_LICENSE ("GPL");
+@@ -1381,6 +1381,11 @@ MODULE_LICENSE ("GPL");
#define PLATFORM_DRIVER ehci_mv_driver
#endif
FEATURES:=ext4 audio
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-LINUX_VERSION:=3.3.3
+LINUX_VERSION:=3.3.4
include $(INCLUDE_DIR)/target.mk
-LINUX_VERSION:=3.3.3
+LINUX_VERSION:=3.3.4
BOARDNAME:=Traverse Geos
FEATURES:=squashfs jffs2 ext4 pci usb gpio
DEFAULT_PACKAGES += \