nagios-plugins: Fix check_procs command
authorHauke Mehrtens <hauke@hauke-m.de>
Thu, 1 May 2014 18:16:09 +0000 (18:16 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 1 May 2014 18:16:09 +0000 (18:16 +0000)
Fix check_procs: ps command line parameters were misconfigured

Signed-off-by: Bernd Krumböck <krumboeck@universalnet.at>
SVN-Revision: 40637

admin/nagios-plugins/Makefile

index 6bb7a23feb335bf451cbe9402406c9b4e5150567..d5fa97e92d7ac607c9e06174838ea8add6b15f1d 100644 (file)
@@ -36,10 +36,10 @@ CONFIGURE_ARGS += \
        --with-openssl="$(STAGING_DIR)/usr" \
        --with-ping-command="/bin/ping -w %d -c %d %s" \
        --with-ping6-command="/bin/ping6 -w %d -c %d %s" \
-       --with-ps-command="/bin/ps -Aopid" \
+       --with-ps-command="/bin/ps w" \
        --with-ps-cols="6" \
        --with-ps-format="%d %s %d %s %s %n" \
-       --with-ps-varlist="&procuid$(comma)&procpid$(comma)&procvsz$(comma)procstat$(comma)procprog$(comma)&pos" \
+       --with-ps-varlist="&procpid$(comma)&procuid$(comma)&procvsz$(comma)procstat$(comma)procprog$(comma)&pos" \
        --with-uptime-command="/usr/bin/uptime" \
        --with-ssh-command="/usr/bin/ssh" \
        --with-nslookup-command="/usr/bin/nslookup"