projects
/
openwrt
/
staging
/
blogic.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
091f6e2
)
modsign: Abort modules_install when signing fails
author
David Woodhouse
<David.Woodhouse@intel.com>
Mon, 20 Jul 2015 20:16:28 +0000
(21:16 +0100)
committer
David Howells
<dhowells@redhat.com>
Fri, 7 Aug 2015 15:26:13 +0000
(16:26 +0100)
Signed-off-by: David Woodhouse <David.Woodhouse@intel.com>
Signed-off-by: David Howells <dhowells@redhat.com>
scripts/Makefile.modinst
patch
|
blob
|
history
diff --git
a/scripts/Makefile.modinst
b/scripts/Makefile.modinst
index e48a4e9d88682b2cdc5834fc5e588eb0eba0e642..07650eeaaf06dd85bb5f3439959ed05c36d8a5ff 100644
(file)
--- a/
scripts/Makefile.modinst
+++ b/
scripts/Makefile.modinst
@@
-22,7
+22,7
@@
quiet_cmd_modules_install = INSTALL $@
mkdir -p $(2) ; \
cp $@ $(2) ; \
$(mod_strip_cmd) $(2)/$(notdir $@) ; \
- $(mod_sign_cmd) $(2)/$(notdir $@) $(patsubst %,|| true,$(KBUILD_EXTMOD))
;
\
+ $(mod_sign_cmd) $(2)/$(notdir $@) $(patsubst %,|| true,$(KBUILD_EXTMOD))
&&
\
$(mod_compress_cmd) $(2)/$(notdir $@)
# Modules built outside the kernel source tree go into extra by default