Port wx200d to -ng
authorFlorian Fainelli <florian@openwrt.org>
Wed, 9 Aug 2006 21:35:08 +0000 (21:35 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 9 Aug 2006 21:35:08 +0000 (21:35 +0000)
SVN-Revision: 4550

utils/wx200d/Makefile [new file with mode: 0644]

diff --git a/utils/wx200d/Makefile b/utils/wx200d/Makefile
new file mode 100644 (file)
index 0000000..25ced23
--- /dev/null
@@ -0,0 +1,57 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=wx200d
+PKG_VERSION:=1.3
+PKG_RELEASE:=1
+PKG_MD5SUM:=0f90c099dddcdd46ac568d707822ec4c
+
+PKG_SOURCE_URL:=@SF/wx200d
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/wx200d
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=+libpq
+  TITLE:=weather station data collector
+  DESCRIPTION:=wx200d is a weather station data collector and server daemon\\\
+  for the WX200, WM918, WMR918 and WMR968 weather station\\\
+  hardware.\\\
+  URL:=http://wx200d.sourceforge.net/
+endef
+
+define Build/Configure
+$(call Build/Configure/Default,--without-libiconv-prefix \
+                       --without-libintl-prefix)
+endef
+
+define Build/Compile
+$(call Build/Compile/Default,DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install)
+endef
+
+define Package/wx200d/install  
+       install -d -m0755 $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/wx200 \
+               $(PKG_INSTALL_DIR)/usr/bin/wxstdout \
+               $(PKG_INSTALL_DIR)/usr/bin/wxfilter \
+               $(PKG_INSTALL_DIR)/usr/bin/wxdebug $(1)/usr/bin/
+       install -d -m0755 $(1)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/wx200d \
+               $(PKG_INSTALL_DIR)/usr/sbin/wxread $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,wx200d))