gemini: apm821xx: Ignore return value of e2fsck
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 5 Oct 2024 13:08:02 +0000 (15:08 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 6 Oct 2024 01:46:45 +0000 (03:46 +0200)
This fixes the build of the gemini and the apm821xx target.
The e2fsck application returns an error code now and that makes the
build fail. The tune2fs command adds an extra option and the e2fsck
should later fix the file system. It is intentionally broken in this
place.

e2fsprogs was patched before to ignore this error.

Fixes: 95e4664b5efc ("tools: e2fsprogs: drop e2fsck patch")
Link: https://github.com/openwrt/openwrt/pull/16607
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/apm821xx/image/Makefile
target/linux/gemini/image/Makefile

index 03799bcc1061d43fe508d0e765ac9400812b91ee..1f09f8de756776766df63342c404750f9dd6b057 100644 (file)
@@ -17,7 +17,8 @@ define Build/boot-img
 
        # convert it to revision 1 - needed for u-boot ext2load
        $(STAGING_DIR_HOST)/bin/tune2fs -O filetype $@.boot
-       $(STAGING_DIR_HOST)/bin/e2fsck -pDf $@.boot > /dev/null
+       # Ignore errors because file system was intentionally broken with tune2fs
+       -$(STAGING_DIR_HOST)/bin/e2fsck -pDf $@.boot > /dev/null
 endef
 
 define Build/boot-script
index 819291ef7fc2fc10f851788b76e6779814aece7b..a7988cf5fbefd7e2c11dd8d024053e80074ad9d2 100644 (file)
@@ -56,7 +56,8 @@ define Build/dns313-images
 
        # The device firmware needs revision 1 of EXT2
        $(STAGING_DIR_HOST)/bin/tune2fs -O filetype $@.tmp-boot
-       $(STAGING_DIR_HOST)/bin/e2fsck -pDf $@.tmp-boot > /dev/null
+       # Ignore errors because file system was intentionally broken with tune2fs
+       -$(STAGING_DIR_HOST)/bin/e2fsck -pDf $@.tmp-boot > /dev/null
 
        ./dns313_gen_hdd_img.sh $@ $@.tmp-boot $(IMAGE_ROOTFS) \
                $(CONFIG_TARGET_KERNEL_PARTSIZE) \