projects
/
openwrt
/
staging
/
lynxis.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
997d4fb
)
base-files: fix conffiles entry check (patch from #2425)
author
Felix Fietkau
<nbd@openwrt.org>
Sat, 19 Sep 2009 23:04:34 +0000
(23:04 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sat, 19 Sep 2009 23:04:34 +0000
(23:04 +0000)
SVN-Revision: 17618
package/base-files/Makefile
patch
|
blob
|
history
diff --git
a/package/base-files/Makefile
b/package/base-files/Makefile
index 6995601a28c374af0d7bf39979eb8a6abd48240a..15920d52b65d84f55efa6a6797b2d396d43dfed9 100644
(file)
--- a/
package/base-files/Makefile
+++ b/
package/base-files/Makefile
@@
-194,7
+194,7
@@
define Package/base-files/install
$(call Package/base-files/install-target,$(1))
for conffile in $(1)/etc/config/*; do \
if [ -f "$$$$conffile" ]; then \
- grep "$$$$
conffile
" $(1)/CONTROL/conffiles || \
+ grep "$$$$
{conffile##$(1)}
" $(1)/CONTROL/conffiles || \
echo "$$$${conffile##$(1)}" >> $(1)/CONTROL/conffiles; \
fi \
done