compat-drivers: remove alx driver from scripts / Makefile
authorLuis R. Rodriguez <mcgrof@do-not-panic.com>
Thu, 18 Oct 2012 22:56:44 +0000 (15:56 -0700)
committerLuis R. Rodriguez <mcgrof@do-not-panic.com>
Fri, 19 Oct 2012 17:25:10 +0000 (10:25 -0700)
This can be reverted once the driver gets onto Linux upstream.

Signed-off-by: Luis R. Rodriguez <mcgrof@do-not-panic.com>
Makefile
scripts/admin-update.sh
scripts/driver-select
scripts/unload.sh

index 771edeff2371436bc0ff119e9de0ef7c0f86be95..52bc9a62d2ca1d465064dfa458482886b64c013f 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -229,7 +229,6 @@ uninstall:
        @rm -rf $(KLIB)/$(KMODDIR)/drivers/net/wireless/
        @rm -rf $(KLIB)/$(KMODDIR)/drivers/staging/
        @rm -rf $(KLIB)/$(KMODDIR)/drivers/net/atl*
-       @find $(KLIB)/$(KMODDIR)/drivers/net/ -name "alx*.ko" -o -name "atl*.ko" 2>/dev/null |xargs rm -f
        @# Lets only remove the stuff we are sure we are providing
        @# on the misc directory.
        @rm -f $(KLIB)/$(KMODDIR)/drivers/misc/eeprom/eeprom_93cx6.ko*
index 43049d6135560634df46da7cd360fb7b5da16334..933e6e46325564d46df844b1d1566f7c3b9580ed 100755 (executable)
@@ -420,8 +420,7 @@ STAGING_DRIVERS=""
 DRIVERS_ETH="drivers/net/ethernet/atheros
             drivers/net/ethernet/atheros/atl1c
             drivers/net/ethernet/atheros/atl1e
-            drivers/net/ethernet/atheros/atlx
-            drivers/net/ethernet/atheros/alx"
+            drivers/net/ethernet/atheros/atlx"
 
 # Bluetooth drivers
 DRIVERS_BT="drivers/bluetooth"
index 640f9fac0f35358bc920ec31c997383ed5d8efba..bfb1e54ece612d2ca9e3c21a61385d444ed8e71a 100755 (executable)
@@ -39,7 +39,7 @@ SUPPORTED_80211_DRIVERS="ath5k ath9k ath9k_ap ath9k_htc carl9170 ath6kl wil6210
 
 # b43 needs some more work for driver-select, the SSB stuff, plus
 # what if you update b44 but not b43? It will bust.
-SUPPORTED_ETH_DRIVERS="atl1 atl2 atl1e atl1c alx"
+SUPPORTED_ETH_DRIVERS="atl1 atl2 atl1e atl1c"
 
 SUPPORTED_DRM_DRIVERS="i915"
 
@@ -74,7 +74,7 @@ function usage {
        echo -e "\t${CYAN}ti${NORMAL} < ${PURPLE} wl1251 wl12xx (SPI and SDIO)${NORMAL}>"
        
        echo -e "\nSupported group drivers: Bluetooth & Ethernet:"
-       echo -e "\t${CYAN}atlxx${NORMAL} < ${PURPLE} atl1 atl2 atl1e alx${NORMAL}>"
+       echo -e "\t${CYAN}atlxx${NORMAL} < ${PURPLE} atl1 atl2 atl1e${NORMAL}>"
        echo -e "\t${CYAN}bt${NORMAL} < ${PURPLE} Linux bluetooth drivers ${NORMAL}>"
 
        echo -e "\nSupported group drivers: DRM:"
@@ -514,11 +514,6 @@ case $1 in
                disable_b44
                echo -e "obj-\$(CONFIG_ATL1C) += atl1c/" > $DRIVERS_NET_ATHEROS
                ;;
-       alx)
-               enable_only_ethernet
-               disable_b44
-               echo -e "obj-\$(CONFIG_ALX) += alx/" > $DRIVERS_NET_ATHEROS
-               ;;
        atlxx)
                select_drivers          CONFIG_ATL1 CONFIG_ATL2 CONFIG_ATL1E CONFIG_ALX
                enable_only_ethernet
index 1f3c5c38b20d7b524b9f2846d0f3f728d3659a09..67fa1508bd8dbe16b4409ec7dbc20141458e9890 100755 (executable)
@@ -36,7 +36,7 @@ MODULES="$MODULES compat"
 # Bluetooth modules
 MODULES="$MODULES ath3k bcm203x bluecard_cs bnep bpa10x bt3c_cs btmrvl btmrvl_sdio btsdio"
 MODULES="$MODULES btusb btuart_cs cmtp dtl1_cs hidp hci_vhci hci_uart rfcomm sco bluetooth l2cap"
-MODULES="$MODULES atl1 atl2 atl1e atl1c alx"
+MODULES="$MODULES atl1 atl2 atl1e atl1c"
 echo Stoping bluetooth service..
 /etc/init.d/bluetooth stop
 /etc/init.d/bluetooth status