imagebuilder: remove initramfs image files
authorChristian Marangi <ansuelsmth@gmail.com>
Tue, 16 Jul 2024 17:00:29 +0000 (19:00 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Tue, 16 Jul 2024 17:05:18 +0000 (19:05 +0200)
Initramfs images are not supported by imagebuilder. With recent changes
to support Per Device Rootfs, we now generate an image and a vmlinux for
each Rootfs and these additional files are all shipped in the
imagebuilder tar.

Drop these new file and any vmlinux-initramfs as they are not used and
increase the final size of the imagebuilder archive.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
target/imagebuilder/Makefile

index 7fd2aa0920e3c014b9daaff508b7df769a7c5268..7127df5ebcd5d4ed510cfe007acff516fcaa8871 100644 (file)
@@ -112,6 +112,9 @@ endif
        -cp $(LINUX_DIR)/.config $(IB_LDIR)/
        rm -f $(IB_KDIR)/root.*
        rm -f $(IB_KDIR)/vmlinux.debug
+       # remove any file for initramfs and Per Device Rootfs initramfs files
+       rm -f $(IB_KDIR)/vmlinux-initramfs*
+       rm -f $(IB_KDIR)/Image-initramfs*
        if [ -x $(LINUX_DIR)/scripts/dtc/dtc ]; then \
                $(INSTALL_DIR) $(IB_LDIR)/scripts/dtc; \
                $(INSTALL_BIN) $(LINUX_DIR)/scripts/dtc/dtc $(IB_LDIR)/scripts/dtc/dtc; \