ipq40xx: define config-names for Aruba boards
authorDavid Bauer <mail@david-bauer.net>
Tue, 10 Sep 2024 02:25:59 +0000 (04:25 +0200)
committerDavid Bauer <mail@david-bauer.net>
Tue, 10 Sep 2024 22:37:34 +0000 (00:37 +0200)
Aruba boards now ship with multiple DTS and image-configurations per
image. Newer apboot revs expect a configuration for their hardware to be
present.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ipq40xx/image/generic.mk

index 0aff89afa331d5da25a86b5382c5aff9f3381c98..a2931ff01e319791c4538eda9f06bc9c07e1de76 100644 (file)
@@ -179,12 +179,14 @@ endef
 define Device/aruba_ap-303
        $(call Device/aruba_glenmorangie)
        DEVICE_MODEL := AP-303
+       DEVICE_DTS_CONFIG := Glenmorangie@1
 endef
 TARGET_DEVICES += aruba_ap-303
 
 define Device/aruba_ap-303h
        $(call Device/aruba_glenmorangie)
        DEVICE_MODEL := AP-303H
+       DEVICE_DTS_CONFIG := Aberlour@1
 endef
 TARGET_DEVICES += aruba_ap-303h
 
@@ -192,6 +194,7 @@ define Device/aruba_ap-365
        $(call Device/aruba_glenmorangie)
        DEVICE_MODEL := AP-365
        DEVICE_PACKAGES := kmod-hwmon-ad7418
+       DEVICE_DTS_CONFIG := Bunker@1
 endef
 TARGET_DEVICES += aruba_ap-365