projects
/
openwrt
/
staging
/
dangole.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
df9781a
)
u-boot.mk: add HOST_LDFLAGS to UBOOT_MAKE_FLAGS
author
Alexandru Ardelean
<ardeleanalex@gmail.com>
Tue, 23 Jan 2018 14:51:52 +0000
(16:51 +0200)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Sat, 10 Feb 2018 19:52:31 +0000
(20:52 +0100)
This will make sure that the build system's
paths for linking are available.
This is needed mostly for linking with tools/libressl.
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
include/u-boot.mk
patch
|
blob
|
history
diff --git
a/include/u-boot.mk
b/include/u-boot.mk
index 5bcf0315d37cf103e2495f4ee6da020518d38a5f..babb76497af033e29e78921e11f558e3dadfaf7e 100644
(file)
--- a/
include/u-boot.mk
+++ b/
include/u-boot.mk
@@
-43,7
+43,7
@@
TARGET_DEP = TARGET_$(BUILD_TARGET)$(if $(BUILD_SUBTARGET),_$(BUILD_SUBTARGET))
UBOOT_MAKE_FLAGS = \
HOSTCC="$(HOSTCC)" \
HOSTCFLAGS="$(HOST_CFLAGS) $(HOST_CPPFLAGS)" \
- HOSTLDFLAGS=""
+ HOSTLDFLAGS="
$(HOST_LDFLAGS)
"
define Build/U-Boot/Target
$(eval $(call U-Boot/Init,$(1)))