projects
/
openwrt
/
staging
/
zorun.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
fae5f02
)
build: fix another regression in append-dtb fix
author
Felix Fietkau
<nbd@nbd.name>
Fri, 3 Nov 2017 15:08:12 +0000
(16:08 +0100)
committer
Felix Fietkau
<nbd@nbd.name>
Fri, 3 Nov 2017 15:21:24 +0000
(16:21 +0100)
Filter out duplicate generated code for the same dts files
Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/image.mk
patch
|
blob
|
history
diff --git
a/include/image.mk
b/include/image.mk
index 2d7b1ef99860e22551f40729cb9463ddf801058b..96a8892115d4e399c46fbf2cc419ad9e2208e4f4 100644
(file)
--- a/
include/image.mk
+++ b/
include/image.mk
@@
-437,10
+437,14
@@
endef
ifndef IB
define Device/Build/dtb
+ ifndef BUILD_DTS_$(1)
+ BUILD_DTS_$(1) := 1
$(KDIR)/image-$(1).dtb: FORCE
$(call Image/BuildDTB,$(strip $(2))/$(1).dts,$$@)
image_prepare: $(KDIR)/image-$(1).dtb
+ endif
+
endef
endif