build: drop SIGNATURE_CHECK and SIGNED_PACKAGES
authorPaul Spooren <mail@aparcar.org>
Thu, 3 Feb 2022 23:15:43 +0000 (00:15 +0100)
committerPaul Spooren <mail@aparcar.org>
Wed, 23 Feb 2022 19:23:56 +0000 (20:23 +0100)
Always sign packages, security by default

Signed-off-by: Paul Spooren <mail@aparcar.org>
config/Config-build.in
package/base-files/Makefile
target/sdk/convert-config.pl
target/sdk/files/Config.in

index 7c808bcbdbc6377dc8ba33dc64442644c14654da..71e66661b3331dacef74deef590d012c4311ee45 100644 (file)
@@ -50,13 +50,6 @@ menu "Global build settings"
                  - Enabling per-device rootfs support
                  ...
 
-       config SIGNED_PACKAGES
-               bool "Cryptographically signed package lists"
-               default y
-
-       config SIGNATURE_CHECK
-               bool "Enable signature checking in opkg"
-               default SIGNED_PACKAGES
 
        comment "General build options"
 
index bef464fcb9aea4c856d7cee15dd4a3732468cbf8..0017f6a218e456bfe9309e27c3775ccd4f5c11a6 100644 (file)
@@ -39,7 +39,7 @@ endif
 define Package/base-files
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=+netifd +libc +jsonfilter +SIGNED_PACKAGES:usign +SIGNED_PACKAGES:openwrt-keyring +NAND_SUPPORT:ubi-utils +fstools +fwtool
+  DEPENDS:=+netifd +libc +jsonfilter usign openwrt-keyring +NAND_SUPPORT:ubi-utils +fstools +fwtool
   TITLE:=Base filesystem for OpenWrt
   URL:=http://openwrt.org/
   VERSION:=$(PKG_RELEASE)-$(REVISION)
index 08189df95cb5f0bf9934909de24f54003dbc4420..24f0ac47a9459dc75b3527a6b2361619523cf615 100755 (executable)
@@ -7,7 +7,6 @@ while (<>) {
        my $val;
        my $type;
        chomp;
-       next if /^CONFIG_SIGNED_PACKAGES/;
 
        if (/^CONFIG_((BINARY)|(DOWNLOAD))_FOLDER=(.*)$/) {
                # We don't want to preserve the build setting of
index aab6352118242bb31d2ff8dae2592002ec3d34f9..4ab8af79baddaf3d0dba2426b8ffcc2e251433ea 100644 (file)
@@ -14,10 +14,6 @@ menu "Global build settings"
                bool "Select all userspace packages by default"
                default y
 
-       config SIGNED_PACKAGES
-               bool "Cryptographically sign package lists"
-               default y
-
        comment "Package build options"
 
        config DEBUG