projects
/
openwrt
/
staging
/
jogo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
1646bd0
)
mac80211: add support for verbose builds using V=sc
author
Felix Fietkau
<nbd@openwrt.org>
Mon, 29 Jul 2013 09:38:08 +0000
(09:38 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Mon, 29 Jul 2013 09:38:08 +0000
(09:38 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 37597
package/kernel/mac80211/Makefile
patch
|
blob
|
history
diff --git
a/package/kernel/mac80211/Makefile
b/package/kernel/mac80211/Makefile
index a1ea8c24c0d62016598a3f55e93c4bafccdff75f..ddf2237ebd6507ceca08b6dafa8b4ae898c4fc68 100644
(file)
--- a/
package/kernel/mac80211/Makefile
+++ b/
package/kernel/mac80211/Makefile
@@
-1299,6
+1299,10
@@
MAKE_OPTS:= -C "$(PKG_BUILD_DIR)" \
KERNEL_SUBLEVEL=$(lastword $(subst ., ,$(KERNEL_PATCHVER))) \
KBUILD_LDFLAGS_MODULE_PREREQ=
+ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)
+ MAKE_OPTS += V=1
+endif
+
define ConfigVars
$(subst $(space),,$(foreach opt,$(config-$(1)),CPTCFG_$(opt)=$(1)
))