projects
/
openwrt
/
staging
/
hauke.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
f37ce3f
)
Add git version check to prerequisite check (#11229)
author
Vasilis Tsiligiannis
<acinonyx@openwrt.gr>
Fri, 6 Apr 2012 12:05:59 +0000
(12:05 +0000)
committer
Vasilis Tsiligiannis
<acinonyx@openwrt.gr>
Fri, 6 Apr 2012 12:05:59 +0000
(12:05 +0000)
SVN-Revision: 31214
include/prereq-build.mk
patch
|
blob
|
history
diff --git
a/include/prereq-build.mk
b/include/prereq-build.mk
index c80e004c0cde3c14d20af263c883ea5b99a913a3..2391e098c684bee20a0da00ec23f86b4defebb21 100644
(file)
--- a/
include/prereq-build.mk
+++ b/
include/prereq-build.mk
@@
-121,8
+121,12
@@
$(eval $(call RequireCommand,wget, \
Please install wget. \
))
-$(eval $(call RequireCommand,git, \
- Please install git (git-core). \
+define Require/git
+ git --version | awk '($$$$1 == "git") && ($$$$2 == "version") && ($$$$3 >= "1.6.5") { print "ok" }' | grep ok > /dev/null
+endef
+
+$(eval $(call Require,git, \
+ Please install git (git-core) v1.6.5 or later. \
))
define Require/gnutar