gcc/binutils: disable sysv style hash tables for generated binaries
authorFelix Fietkau <nbd@nbd.name>
Tue, 16 Aug 2022 17:35:50 +0000 (19:35 +0200)
committerFelix Fietkau <nbd@nbd.name>
Thu, 14 Nov 2024 12:04:24 +0000 (13:04 +0100)
GNU hash tables are always preferred by musl, so the sysv ones are completely
unused and only waste space. Reduces image size by ~1.4%

Signed-off-by: Felix Fietkau <nbd@nbd.name>
toolchain/binutils/Makefile
toolchain/build_version
toolchain/gcc/common.mk

index 63f0e07ccf69f1dbb2331a5c927653cffbb1db1b..2c715d45ee4140a40b5b3e291a404e22019210b7 100644 (file)
@@ -49,6 +49,7 @@ HOST_CONFIGURE_ARGS = \
        --with-system-zlib \
        --with-zstd \
        --enable-deterministic-archives \
+       $(if $(findstring mips,$(ARCH)),,--enable-default-hash-style=gnu) \
        --enable-plugins \
        --enable-lto \
        --disable-gprofng \
index d00491fd7e5bb6fa28c517a0bb32b8b506539d4d..0cfbf08886fca9a91cb753ec8734c84fcbe52c9f 100644 (file)
@@ -1 +1 @@
-1
+2
index 0ccf55bd313ca20d1f4dc7e1fb507e85f69e3f4e..9170da5bf0e9788e2c971371bc8922a05cdc2d51 100644 (file)
@@ -108,6 +108,7 @@ GCC_CONFIGURE:= \
                --disable-libssp \
                $(GRAPHITE_CONFIGURE) \
                --with-host-libstdcxx=-lstdc++ \
+               $(if $(findstring mips,$(ARCH)),,--with-linker-hash-style=gnu) \
                $(SOFT_FLOAT_CONFIG_OPTION) \
                $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
                $(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 \