projects
/
openwrt
/
staging
/
zorun.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
e8487a4
)
fix libtool fixup for libstdc++
author
Felix Fietkau
<nbd@openwrt.org>
Thu, 19 Aug 2010 17:46:11 +0000
(17:46 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Thu, 19 Aug 2010 17:46:11 +0000
(17:46 +0000)
SVN-Revision: 22732
include/autotools.mk
patch
|
blob
|
history
diff --git
a/include/autotools.mk
b/include/autotools.mk
index c941a4949d09a0f1d8a036b4c709e81f54f49b19..1ddb49b7d4f07f1588acd15ba965f3f395f2cc92 100644
(file)
--- a/
include/autotools.mk
+++ b/
include/autotools.mk
@@
-38,7
+38,7
@@
autoconf_bool = $(patsubst %,$(if $($(1)),--enable,--disable)-%,$(2))
define libtool_fixup_libdir
find $(1) -name '*.la' | $(XARGS) \
$(SED) "s,\(^libdir='\| \|-L\|^dependency_libs='\)/usr/lib,\1$(STAGING_DIR)/usr/lib,g" \
- -e "s,$(STAGING_DIR)/usr/lib/\(libstdc++\|libsupc++\).la,$(TOOLCHAIN_DIR)/
usr/
lib/\1.la,g"
+ -e "s,$(STAGING_DIR)/usr/lib/\(libstdc++\|libsupc++\).la,$(TOOLCHAIN_DIR)/lib/\1.la,g"
endef
define remove_version_check