tools/cmake: Update to 3.30.2
authorHannu Nyman <hannu.nyman@iki.fi>
Sat, 3 Aug 2024 06:46:18 +0000 (09:46 +0300)
committerRobert Marko <robimarko@gmail.com>
Tue, 13 Aug 2024 09:11:36 +0000 (11:11 +0200)
Update cmake to version 3.30.2
Release notes: https://cmake.org/cmake/help/v3.30/release/3.30.html

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Link: https://github.com/openwrt/openwrt/pull/16059
Signed-off-by: Robert Marko <robimarko@gmail.com>
tools/cmake/Makefile
tools/cmake/patches/110-liblzma.patch
tools/cmake/patches/120-curl-fix-libressl-linking.patch
tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
tools/cmake/patches/140-zlib.patch
tools/cmake/patches/160-disable_xcode_generator.patch

index 89194ac5d7a8de79e00bd6952402004ef0beef86..c612e7e40599c2147c3ea8c5f9ebdb7ceaa48a3d 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cmake
-PKG_VERSION:=3.29.5
+PKG_VERSION:=3.30.2
 PKG_VERSION_MAJOR:=$(word 1,$(subst ., ,$(PKG_VERSION))).$(word 2,$(subst ., ,$(PKG_VERSION)))
 PKG_RELEASE:=1
 PKG_CPE_ID:=cpe:/a:kitware:cmake
@@ -15,7 +15,7 @@ PKG_CPE_ID:=cpe:/a:kitware:cmake
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/Kitware/CMake/releases/download/v$(PKG_VERSION)/ \
                https://cmake.org/files/v$(PKG_VERSION_MAJOR)/
-PKG_HASH:=dd63da7d763c0db455ca232f2c443f5234fe0b11f8bd6958a81d29cc987dfd6e
+PKG_HASH:=46074c781eccebc433e98f0bbfa265ca3fd4381f245ca3b140e7711531d60db2
 
 HOST_BUILD_PARALLEL:=1
 HOST_CONFIGURE_PARALLEL:=1
index d7cbd434a164f1dfa3aed47a175c39add5255b3b..4b8ec0d33f55bfbe5cccdc1705fc1c83dec96b08 100644 (file)
@@ -1,8 +1,8 @@
 --- a/Modules/FindLibLZMA.cmake
 +++ b/Modules/FindLibLZMA.cmake
-@@ -58,7 +58,13 @@ The following variables are provided for
- #]=======================================================================]
+@@ -61,7 +61,13 @@ The following variables are provided for
+ cmake_policy(PUSH)
+ cmake_policy(SET CMP0159 NEW) # file(STRINGS) with REGEX updates CMAKE_MATCH_<n>
  
 -find_path(LIBLZMA_INCLUDE_DIR lzma.h )
 +if(UNIX)
index a46acd63dae2f24f69057741ad543841e7d4c30d..19217343d1cc7bb4bd637921ef46dce9cc4a8b4c 100644 (file)
@@ -20,7 +20,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
 ---
 --- a/Utilities/cmcurl/CMakeLists.txt
 +++ b/Utilities/cmcurl/CMakeLists.txt
-@@ -647,6 +647,14 @@ if(CURL_USE_OPENSSL)
+@@ -648,6 +648,14 @@ if(CURL_USE_OPENSSL)
    endif()
    set(SSL_ENABLED ON)
    set(USE_OPENSSL ON)
index ffe47f9901a72531545198437701bf27956c215f..a2a873fcea943904a03a971db74dc106bc6a08d9 100644 (file)
@@ -1,6 +1,6 @@
 --- a/bootstrap
 +++ b/bootstrap
-@@ -1493,7 +1493,10 @@ int main(){ printf("1%c", (char)0x0a); r
+@@ -1509,7 +1509,10 @@ int main(){ printf("1%c", (char)0x0a); r
  ' > "test.c"
  cmake_original_make_flags="${cmake_make_flags}"
  if test "x${cmake_parallel_make}" != "x"; then
index 8b7b7de1b04c0bf9f5a7a4e2e698c27c39062aad..17334a66e0fa59e02254ec44204b11067b4a185e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Modules/FindZLIB.cmake
 +++ b/Modules/FindZLIB.cmake
-@@ -117,10 +117,13 @@ else()
+@@ -120,10 +120,13 @@ else()
    set(ZLIB_NAMES_DEBUG zd zlibd zdlld zlibd1 zlib1d zlibstaticd zlibwapid zlibvcd zlibstatd)
  endif()
  
index 20d1086bd47b4cbd7c9216722be18cdc8ede9a4b..0e29dedd9b403838d90f3db22a785a6b17993d75 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Source/CMakeLists.txt
 +++ b/Source/CMakeLists.txt
-@@ -846,7 +846,7 @@ if(CMake_USE_XCOFF_PARSER)
+@@ -858,7 +858,7 @@ if(CMake_USE_XCOFF_PARSER)
  endif()
  
  # Xcode only works on Apple
@@ -11,7 +11,7 @@
      PRIVATE
 --- a/Source/cmake.cxx
 +++ b/Source/cmake.cxx
-@@ -132,7 +132,7 @@
+@@ -134,7 +134,7 @@
  #  include "cmGlobalGhsMultiGenerator.h"
  #endif