projects
/
openwrt
/
staging
/
dangole.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
5a5c520
)
image: add missing DTC include-prefixes directory
author
Álvaro Fernández Rojas
<noltari@gmail.com>
Fri, 10 May 2024 11:39:07 +0000
(13:39 +0200)
committer
Álvaro Fernández Rojas
<noltari@gmail.com>
Fri, 10 May 2024 19:02:24 +0000
(21:02 +0200)
include-prefixes were moved to a common directory in linux v4.12, see
https://github.com/torvalds/linux/commit/
d5d332d3f7e8435e264a71b90178dee69428d630
This is needed for bcm27xx kernel v6.6 support.
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
include/image.mk
patch
|
blob
|
history
diff --git
a/include/image.mk
b/include/image.mk
index 284298e5ed69a2cefb071f9764b9acfa0a4826f0..0dd18dbd82714e835c07f59864bf4cd62ead01c2 100644
(file)
--- a/
include/image.mk
+++ b/
include/image.mk
@@
-185,6
+185,7
@@
define Image/BuildDTB/sub
-I$(DTS_DIR) \
-I$(DTS_DIR)/include \
-I$(LINUX_DIR)/include/ \
+ -I$(LINUX_DIR)/scripts/dtc/include-prefixes \
-undef -D__DTS__ $(3) \
-o $(2).tmp $(1)
$(LINUX_DIR)/scripts/dtc/dtc -O dtb \