Move mac80211 rate control option to 08-change-default-rate-alg.patch
authorLuis R. Rodriguez <lrodriguez@atheros.com>
Tue, 4 Aug 2009 20:43:59 +0000 (13:43 -0700)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Tue, 4 Aug 2009 20:43:59 +0000 (13:43 -0700)
Since your current kernel's config is *always* respected we
we renamed a config option:

s|CONFIG_MAC80211_RC_DEFAULT|
  CONFIG_COMPAT_MAC80211_RC_DEFAULT

We do this so that our new preference for rate control
algorithm is respected, currently minstrel.

Signed-off-by: Luis R. Rodriguez <lrodriguez@atheros.com>
compat/compat.diff
compat/diffs/08-change-default-rate-alg.patch [new file with mode: 0644]

index 9b0ac408bb932388878c4d3f3de9858d73427008..e8a16ba9680a03854691bf519648db5805d6d194 100644 (file)
 -obj-$(CONFIG_USB_NET_INT51X1) += int51x1.o
 -obj-$(CONFIG_USB_CDC_PHONET)  += cdc-phonet.o
  
---- a/net/mac80211/rate.c
-+++ b/net/mac80211/rate.c
-@@ -22,7 +22,7 @@ struct rate_control_alg {
- static LIST_HEAD(rate_ctrl_algs);
- static DEFINE_MUTEX(rate_ctrl_mutex);
--static char *ieee80211_default_rc_algo = CONFIG_MAC80211_RC_DEFAULT;
-+static char *ieee80211_default_rc_algo = CONFIG_COMPAT_MAC80211_RC_DEFAULT;
- module_param(ieee80211_default_rc_algo, charp, 0644);
- MODULE_PARM_DESC(ieee80211_default_rc_algo,
-                "Default rate control algorithm for mac80211 to use");
-@@ -117,8 +117,8 @@ ieee80211_rate_control_ops_get(const char *name)
-               ops = ieee80211_try_rate_control_ops_get(ieee80211_default_rc_algo);
-       /* try built-in one if specific alg requested but not found */
--      if (!ops && strlen(CONFIG_MAC80211_RC_DEFAULT))
--              ops = ieee80211_try_rate_control_ops_get(CONFIG_MAC80211_RC_DEFAULT);
-+      if (!ops && strlen(CONFIG_COMPAT_MAC80211_RC_DEFAULT))
-+              ops = ieee80211_try_rate_control_ops_get(CONFIG_COMPAT_MAC80211_RC_DEFAULT);
-       return ops;
- }
 --- a/drivers/net/wireless/Makefile    2009-07-06 12:53:07.479194884 -0700
 +++ b/drivers/net/wireless/Makefile    2009-07-06 12:54:42.026195576 -0700
 @@ -5,43 +5,16 @@
diff --git a/compat/diffs/08-change-default-rate-alg.patch b/compat/diffs/08-change-default-rate-alg.patch
new file mode 100644 (file)
index 0000000..96aa4e2
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/net/mac80211/rate.c
++++ b/net/mac80211/rate.c
+@@ -22,7 +22,7 @@ struct rate_control_alg {
+ static LIST_HEAD(rate_ctrl_algs);
+ static DEFINE_MUTEX(rate_ctrl_mutex);
+-static char *ieee80211_default_rc_algo = CONFIG_MAC80211_RC_DEFAULT;
++static char *ieee80211_default_rc_algo = CONFIG_COMPAT_MAC80211_RC_DEFAULT;
+ module_param(ieee80211_default_rc_algo, charp, 0644);
+ MODULE_PARM_DESC(ieee80211_default_rc_algo,
+                "Default rate control algorithm for mac80211 to use");
+@@ -117,8 +117,8 @@ ieee80211_rate_control_ops_get(const char *name)
+               ops = ieee80211_try_rate_control_ops_get(ieee80211_default_rc_algo);
+       /* try built-in one if specific alg requested but not found */
+-      if (!ops && strlen(CONFIG_MAC80211_RC_DEFAULT))
+-              ops = ieee80211_try_rate_control_ops_get(CONFIG_MAC80211_RC_DEFAULT);
++      if (!ops && strlen(CONFIG_COMPAT_MAC80211_RC_DEFAULT))
++              ops = ieee80211_try_rate_control_ops_get(CONFIG_COMPAT_MAC80211_RC_DEFAULT);
+       return ops;
+ }