-diff -urN openntpd-3.7p1.orig/client.c openntpd-3.7p1/client.c
---- openntpd-3.7p1.orig/client.c 2005-03-13 13:36:38.000000000 +0100
-+++ openntpd-3.7p1/client.c 2006-02-23 16:27:53.686827824 +0100
-@@ -306,7 +306,7 @@
+diff -urN openntpd-3.9p1/client.c openntpd-3.9p1.new/client.c
+--- openntpd-3.9p1/client.c 2006-05-14 07:29:21.000000000 +0200
++++ openntpd-3.9p1.new/client.c 2006-11-03 11:05:18.000000000 +0100
+@@ -321,7 +321,7 @@
priv_adjtime();
for (i = 0; i < OFFSET_ARRAY_SIZE; i++)
p->reply[i].good = 0;
return (0);
-diff -urN openntpd-3.7p1.orig/configure.ac openntpd-3.7p1/configure.ac
---- openntpd-3.7p1.orig/configure.ac 2005-05-23 13:11:08.000000000 +0200
-+++ openntpd-3.7p1/configure.ac 2006-02-23 16:27:53.688827520 +0100
-@@ -466,6 +466,11 @@
+diff -urN openntpd-3.9p1/configure.ac openntpd-3.9p1.new/configure.ac
+--- openntpd-3.9p1/configure.ac 2006-05-14 07:29:23.000000000 +0200
++++ openntpd-3.9p1.new/configure.ac 2006-11-03 11:06:26.000000000 +0100
+@@ -583,6 +583,12 @@
[ builtin_arc4random=$withval ]
)
+ [ AC_DEFINE(USE_ADJTIMEX, [], [Use adjust skew with adjtimex (experimental)]) ]
+)
+
- # Search for OpenSSL if required.
- if test "$ac_cv_func_arc4random" != "yes" && test "x$builtin_arc4random" != "xyes"; then
- saved_CPPFLAGS="$CPPFLAGS"
-diff -urN openntpd-3.7p1.orig/defines.h openntpd-3.7p1/defines.h
---- openntpd-3.7p1.orig/defines.h 2005-05-23 02:16:33.000000000 +0200
-+++ openntpd-3.7p1/defines.h 2006-02-23 16:27:53.688827520 +0100
++
+ AC_ARG_WITH(mantype,
+ [ --with-mantype=man|cat|doc Set man page type],
+ [
+diff -urN openntpd-3.9p1/defines.h openntpd-3.9p1.new/defines.h
+--- openntpd-3.9p1/defines.h 2006-05-14 07:29:21.000000000 +0200
++++ openntpd-3.9p1.new/defines.h 2006-11-03 11:06:56.000000000 +0100
@@ -20,6 +20,10 @@
# define setproctitle(x)
#endif
+#ifdef USE_ADJTIMEX
-+# define adjtime(a,b) (_compat_adjtime((a),(b)))
++# define adjtime(a,b) (_compat_adjtime((a),(b)))
+#endif
+
#if !defined(SA_LEN)
# if defined(HAVE_STRUCT_SOCKADDR_SA_LEN)
# define SA_LEN(x) ((x)->sa_len)
-diff -urN openntpd-3.7p1.orig/openbsd-compat/Makefile.in openntpd-3.7p1/openbsd-compat/Makefile.in
---- openntpd-3.7p1.orig/openbsd-compat/Makefile.in 2004-12-20 00:41:36.000000000 +0100
-+++ openntpd-3.7p1/openbsd-compat/Makefile.in 2006-02-23 16:27:53.901795144 +0100
+diff -urN openntpd-3.9p1/openbsd-compat/Makefile.in openntpd-3.9p1.new/openbsd-compat/Makefile.in
+--- openntpd-3.9p1/openbsd-compat/Makefile.in 2006-05-14 07:29:19.000000000 +0200
++++ openntpd-3.9p1.new/openbsd-compat/Makefile.in 2006-11-03 11:07:20.000000000 +0100
@@ -9,7 +9,7 @@
- OPENBSD= asprintf.o daemon.o inet_pton.o strlcpy.o
COMPAT= atomicio.o bsd-arc4random.o bsd-misc.o bsd-poll.o \
- bsd-snprintf.o fake-rfc2553.o uidswap.o
+ bsd-snprintf.o bsd-getifaddrs.o bsd-setresuid.o \
+ bsd-setresgid.o fake-rfc2553.o
-PORT= port-qnx.o
+PORT= port-linux.o port-qnx.o
VPATH=@srcdir@
CC=@CC@
-diff -urN openntpd-3.7p1.orig/openbsd-compat/openbsd-compat.h openntpd-3.7p1/openbsd-compat/openbsd-compat.h
---- openntpd-3.7p1.orig/openbsd-compat/openbsd-compat.h 2004-12-19 04:04:22.000000000 +0100
-+++ openntpd-3.7p1/openbsd-compat/openbsd-compat.h 2006-02-23 16:27:53.948788000 +0100
-@@ -44,6 +44,11 @@
+diff -urN openntpd-3.9p1/openbsd-compat/openbsd-compat.h openntpd-3.9p1.new/openbsd-compat/openbsd-compat.h
+--- openntpd-3.9p1/openbsd-compat/openbsd-compat.h 2006-05-14 07:29:19.000000000 +0200
++++ openntpd-3.9p1.new/openbsd-compat/openbsd-compat.h 2006-11-03 11:07:55.000000000 +0100
+@@ -46,6 +46,11 @@
__attribute__((__format__ (printf, 2, 3)));
#endif
#ifndef HAVE_INET_PTON
int inet_pton(int, const char *, void *);
#endif
-diff -urN openntpd-3.7p1.orig/openbsd-compat/port-linux.c openntpd-3.7p1/openbsd-compat/port-linux.c
---- openntpd-3.7p1.orig/openbsd-compat/port-linux.c 1970-01-01 01:00:00.000000000 +0100
-+++ openntpd-3.7p1/openbsd-compat/port-linux.c 2006-02-23 16:27:53.996780704 +0100
+diff -urN openntpd-3.9p1/openbsd-compat/port-linux.c openntpd-3.9p1.new/openbsd-compat/port-linux.c
+--- openntpd-3.9p1/openbsd-compat/port-linux.c 1970-01-01 01:00:00.000000000 +0100
++++ openntpd-3.9p1.new/openbsd-compat/port-linux.c 2006-11-03 11:08:57.000000000 +0100
@@ -0,0 +1,105 @@
+/* $Id$ */
+