include $(TOPDIR)/rules.mk
PKG_NAME:=vpnc
-PKG_VERSION:=0.4.0
+PKG_VERSION:=0.5.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.unix-ag.uni-kl.de/~massar/vpnc/
-PKG_MD5SUM:=604807e7dd90fce00a4e2344ee29c76d
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=7a8e94dbe94f39a4fd89b72e0125f66f
include $(INCLUDE_DIR)/package.mk
SECTION:=net
CATEGORY:=Network
DEPENDS:=+libgpg-error +libgcrypt +kmod-tun +ip
- TITLE:=VPN client for Cisco 3000
+ TITLE:=VPN client for Cisco EasyVPN
URL:=http://www.unix-ag.uni-kl.de/~massar/vpnc/
SUBMENU:=VPN
endef
+define Package/vpnc/description
+ A VPN client compatible with Cisco's EasyVPN equipment.
+
+ Supports IPSec (ESP) with Mode Configuration and Xauth. Supports only
+ shared-secret IPSec authentication with Xauth, AES (256, 192, 128),
+ 3DES, 1DES, MD5, SHA1, DH1/2/5 and IP tunneling.
+endef
+
define Package/vpnc/conffiles
/etc/vpnc/default.conf
/etc/vpnc/vpnc-script
-diff -Nur vpnc-0.4.0/Makefile vpnc-0.4.0.patched/Makefile
---- vpnc-0.4.0/Makefile 2007-02-19 21:51:12.000000000 +0100
-+++ vpnc-0.4.0.patched/Makefile 2007-02-25 10:40:25.000000000 +0100
+--- a/Makefile
++++ b/Makefile
@@ -20,7 +20,7 @@
- # $Id: Makefile 148 2007-02-19 20:51:14Z Maurice Massar $
+ # $Id: Makefile 236 2007-09-05 20:40:59Z Joerg Mayer $
DESTDIR=
-PREFIX=/usr/local
ETCDIR=/etc/vpnc
BINDIR=$(PREFIX)/bin
SBINDIR=$(PREFIX)/sbin
-@@ -35,12 +35,11 @@
- RELEASE_VERSION := $(shell cat VERSION)
+@@ -50,14 +50,11 @@
+ #OPENSSLLIBS = -lcrypto
CC=gcc
--CFLAGS += -W -Wall -O3 -Wmissing-declarations -Wwrite-strings -g
-+CFLAGS += -W -Wall -Wmissing-declarations -Wwrite-strings -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include $(OFLAGS) '-DVERSION="$(shell cat VERSION)"'
- CPPFLAGS = -DVERSION=\"$(VERSION)\"
--LDFLAGS = -g $(shell libgcrypt-config --libs)
+-CFLAGS ?= -O3 -g
+-CFLAGS += -W -Wall -Wmissing-declarations -Wwrite-strings
-CFLAGS += $(shell libgcrypt-config --cflags)
++CFLAGS += -W -Wall -Wmissing-declarations -Wwrite-strings -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include $(OFLAGS) '-DVERSION="$(shell cat VERSION)"'
+ CPPFLAGS += -DVERSION=\"$(VERSION)\" $(OPENSSL_GPL_VIOLATION)
+-LDFLAGS ?= -g
+-LDFLAGS += $(shell libgcrypt-config --libs) $(OPENSSLLIBS)
+LDFLAGS = -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -lgcrypt -lgpg-error
-ifeq ($(shell uname -s), SunOS)
+ifeq ($(OS), SunOS)
LDFLAGS += -lnsl -lresolv -lsocket
endif
-
+ ifneq (,$(findstring Apple,$(shell $(CC) --version)))
---- vpnc-0.4.0/vpnc-script 2007-02-18 12:52:03.000000000 +0100
-+++ vpnc-0.4.0.patched/vpnc-script 2007-02-25 11:34:06.000000000 +0100
-@@ -107,7 +107,7 @@
- }
+--- a/vpnc-script
++++ b/vpnc-script
+@@ -95,7 +95,7 @@
+ # =========== tunnel interface handling ====================================
do_ifconfig() {
- ifconfig "$TUNDEV" inet "$INTERNAL_IP4_ADDRESS" $ifconfig_syntax_ptp "$INTERNAL_IP4_ADDRESS" netmask 255.255.255.255 mtu 1412 up
}
destroy_tun_device() {
-@@ -388,6 +388,18 @@
+@@ -490,6 +490,18 @@
fi
}
+ iptables -D forwarding_rule -o $TUNDEV -j ACCEPT
+}
+
- ####
+ #### Main
if [ -z "$reason" ]; then
-@@ -401,8 +413,10 @@
+@@ -503,8 +515,10 @@
;;
connect)
do_connect