projects
/
openwrt
/
staging
/
dangole.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
19e3ec0
)
kernel: make libsas depend on x86
author
Felix Fietkau
<nbd@openwrt.org>
Thu, 11 Jul 2013 20:56:22 +0000
(20:56 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Thu, 11 Jul 2013 20:56:22 +0000
(20:56 +0000)
It is only used by one driver that already depends on x86. Disabling it
prevents a few kilobytes of bloat from leaking into all targets via
CONFIG_BLK_DEV_BSG
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 37254
package/kernel/linux/modules/block.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/block.mk
b/package/kernel/linux/modules/block.mk
index 1aa47def2d504c913f965d389f991e8b10fb63d9..d92010b8c96d1b489b6ca17ef68b98b5a33eaf60 100644
(file)
--- a/
package/kernel/linux/modules/block.mk
+++ b/
package/kernel/linux/modules/block.mk
@@
-491,6
+491,7
@@
$(eval $(call KernelPackage,ide-it821x))
define KernelPackage/libsas
SUBMENU:=$(BLOCK_MENU)
+ DEPENDS:=@TARGET_x86
TITLE:=SAS Domain Transport Attributes
KCONFIG:=CONFIG_SCSI_SAS_LIBSAS \
CONFIG_SCSI_SAS_ATTRS \