include $(TOPDIR)/rules.mk
PKG_NAME:=imx-bootlets
-PKG_VERSION:=10.05.02
+PKG_VERSION:=10.12.01
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://trabant.uid0.hu/openwrt/
-PKG_HASH:=09ecd81a64db5166a235932146faf08d0689bfc7ac04ac9fcc3a5bd809fba74a
+PKG_HASH:=f7c98cbc41e15184cad61c56115e840e34ac3ebb4a162fadeea905e5038fd65b
PKG_FLAGS:=nonshared
$(INSTALL_BIN) $(PKG_BUILD_DIR)/boot_prep/boot_prep $(STAGING_DIR)/boot_prep
$(INSTALL_BIN) $(PKG_BUILD_DIR)/linux_prep/output-target/linux_prep $(STAGING_DIR)/linux_prep
$(INSTALL_BIN) $(PKG_BUILD_DIR)/power_prep/power_prep $(STAGING_DIR)/power_prep
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/linux_prebuilt.db $(STAGING_DIR)/linux_prebuilt.db
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/linux_ivt.bd $(STAGING_DIR)/linux_ivt.bd
endef
$(eval $(call BuildPackage,imx-bootlets))
--- a/Makefile
+++ b/Makefile
-@@ -32,10 +32,11 @@ ifeq "$(DFT_IMAGE)" "$(wildcard $(DFT_IM
- sed -i 's,[^ *]image.*;,\timage="$(DFT_UBOOT)";,' uboot.db
- elftosb2 -z -c ./uboot.db -o i$(ARCH)_uboot.sb
+@@ -37,13 +37,13 @@ ifeq "$(DFT_IMAGE)" "$(wildcard $(DFT_IM
+ elftosb -z -c ./uboot.bd -o i$(ARCH)_uboot.sb
+ elftosb -z -f imx28 -c ./uboot_ivt.bd -o i$(ARCH)_ivt_uboot.sb
else
- @echo "by using the pre-built kernel"
-- elftosb2 -z -c ./linux_prebuilt.db -o i$(ARCH)_linux.sb
-- @echo "generating U-Boot boot stream image"
-- elftosb2 -z -c ./uboot_prebuilt.db -o i$(ARCH)_uboot.sb
+- elftosb -z -c ./linux.bd -o i$(ARCH)_linux.sb
+- elftosb -z -f imx28 -c ./linux_ivt.bd -o i$(ARCH)_ivt_linux.sb
+ @echo "... not generating any image for now."
-+ #@echo "by using the pre-built kernel"
-+ #elftosb2 -z -c ./linux_prebuilt.db -o i$(ARCH)_linux.sb
++ #elftosb -z -c ./linux.bd -o i$(ARCH)_linux.sb
++ #elftosb -z -f imx28 -c ./linux_ivt.bd -o i$(ARCH)_ivt_linux.sb
+
+- @echo "generating U-Boot boot stream image"
+- elftosb -z -c ./uboot.bd -o i$(ARCH)_uboot.sb
+- elftosb -z -f imx28 -c ./uboot_ivt.bd -o i$(ARCH)_ivt_uboot.sb
+ #@echo "generating U-Boot boot stream image"
-+ #elftosb2 -z -c ./uboot_prebuilt.db -o i$(ARCH)_uboot.sb
++ #elftosb -z -c ./uboot.bd -o i$(ARCH)_uboot.sb
++ #elftosb -z -f imx28 -c ./uboot_ivt.bd -o i$(ARCH)_ivt_uboot.sb
endif
#@echo "generating kernel bootstream file sd_mmc_bootstream.raw"
#Please use cfimager to burn xxx_linux.sb. The below way will no
---- a/linux_prebuilt.db
-+++ b/linux_prebuilt.db
+--- a/linux_ivt.bd
++++ b/linux_ivt.bd
@@ -4,10 +4,10 @@ options {
flags = 0x01;
}
- power_prep="./power_prep/power_prep";
- sdram_prep="./boot_prep/boot_prep";
- linux_prep="./linux_prep/output-target/linux_prep";
-- zImage = "./zImage";
+- zImage="./zImage";
+ power_prep="./power_prep";
+ sdram_prep="./boot_prep";
+ linux_prep="./linux_prep";
-+ zImage = "./zImage_dtb";
++ zImage="./zImage_dtb";
}
section (0) {
all: build_prep gen_bootstream
-@@ -94,6 +97,8 @@ distclean: clean
+@@ -101,6 +104,8 @@ distclean: clean
clean:
-rm -rf *.sb
rm -f sd_mmc_bootstream.raw
$(MAKE) -C linux_prep clean ARCH=$(ARCH)
$(MAKE) -C boot_prep clean ARCH=$(ARCH)
$(MAKE) -C power_prep clean ARCH=$(ARCH)
---- a/uboot.db
-+++ b/uboot.db
-@@ -3,7 +3,7 @@
- sources {
- power_prep="./power_prep/power_prep";
- sdram_prep="./boot_prep/boot_prep";
-- image="/home/b18647/repos/ltib_latest/rootfs/boot/u-boot";
-+ image="../boot/u-boot";
- }
-
- section (0) {
--- /dev/null
+--- a/linux_prep/core/cmdlines.S
++++ b/linux_prep/core/cmdlines.S
+@@ -14,7 +14,7 @@
+ #define CMDLINES_FILE "output-target/command_lines_stripped.txt"
+ #endif
+
+- .section .cmdlines, #alloc
++ .section .cmdlines, "a"
+ .globl cmdlines_start
+ cmdlines_start:
+ .incbin CMDLINES_FILE