imx-bootlets: bump to 10.12.01
authorZoltan HERPAI <wigyori@uid0.hu>
Wed, 5 Feb 2025 15:41:08 +0000 (16:41 +0100)
committerZoltan HERPAI <wigyori@uid0.hu>
Wed, 5 Feb 2025 21:00:09 +0000 (22:00 +0100)
 - refresh patches
 - add patch to fix compilation with GCC13
   (referring to ARM-8933/1).

Link: https://lore.kernel.org/lkml/20220630133231.272605764@linuxfoundation.org/
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
package/boot/imx-bootlets/Makefile
package/boot/imx-bootlets/patches/001-skip_sb_generation.patch
package/boot/imx-bootlets/patches/002-set_elftosb_config.patch
package/boot/imx-bootlets/patches/003-add-olinuxino.patch
package/boot/imx-bootlets/patches/004-fix-ARM-8933_1.patch [new file with mode: 0644]

index de976c249a63bff51a7747bb11ca392d05b06a91..0ecb0f2dfde605c6236869840ef27d18046bf20c 100644 (file)
@@ -7,11 +7,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=imx-bootlets
-PKG_VERSION:=10.05.02
+PKG_VERSION:=10.12.01
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://trabant.uid0.hu/openwrt/
-PKG_HASH:=09ecd81a64db5166a235932146faf08d0689bfc7ac04ac9fcc3a5bd809fba74a
+PKG_HASH:=f7c98cbc41e15184cad61c56115e840e34ac3ebb4a162fadeea905e5038fd65b
 
 PKG_FLAGS:=nonshared
 
@@ -37,7 +37,7 @@ define Package/imx-bootlets/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/boot_prep/boot_prep $(STAGING_DIR)/boot_prep
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/linux_prep/output-target/linux_prep $(STAGING_DIR)/linux_prep
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/power_prep/power_prep $(STAGING_DIR)/power_prep
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/linux_prebuilt.db $(STAGING_DIR)/linux_prebuilt.db
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/linux_ivt.bd $(STAGING_DIR)/linux_ivt.bd
 endef
 
 $(eval $(call BuildPackage,imx-bootlets))
index ad652658503021d0718e3d22bc2d683b405918a0..d1829aa16c003576195e21c6201a29ad7f90330f 100644 (file)
@@ -1,18 +1,22 @@
 --- a/Makefile
 +++ b/Makefile
-@@ -32,10 +32,11 @@ ifeq "$(DFT_IMAGE)" "$(wildcard $(DFT_IM
-       sed -i 's,[^ *]image.*;,\timage="$(DFT_UBOOT)";,' uboot.db
-       elftosb2 -z -c ./uboot.db -o i$(ARCH)_uboot.sb
+@@ -37,13 +37,13 @@ ifeq "$(DFT_IMAGE)" "$(wildcard $(DFT_IM
+       elftosb -z -c ./uboot.bd -o i$(ARCH)_uboot.sb
+       elftosb -z -f imx28 -c ./uboot_ivt.bd -o i$(ARCH)_ivt_uboot.sb
  else
 -      @echo "by using the pre-built kernel"
--      elftosb2 -z -c ./linux_prebuilt.db -o i$(ARCH)_linux.sb
--      @echo "generating U-Boot boot stream image"
--      elftosb2 -z -c ./uboot_prebuilt.db -o i$(ARCH)_uboot.sb
+-      elftosb -z -c ./linux.bd -o i$(ARCH)_linux.sb
+-      elftosb -z -f imx28 -c  ./linux_ivt.bd -o i$(ARCH)_ivt_linux.sb
 +      @echo "... not generating any image for now."
-+      #@echo "by using the pre-built kernel"
-+      #elftosb2 -z -c ./linux_prebuilt.db -o i$(ARCH)_linux.sb
++      #elftosb -z -c ./linux.bd -o i$(ARCH)_linux.sb
++      #elftosb -z -f imx28 -c  ./linux_ivt.bd -o i$(ARCH)_ivt_linux.sb
+-      @echo "generating U-Boot boot stream image"
+-      elftosb -z -c ./uboot.bd -o i$(ARCH)_uboot.sb
+-      elftosb -z -f imx28 -c ./uboot_ivt.bd -o i$(ARCH)_ivt_uboot.sb
 +      #@echo "generating U-Boot boot stream image"
-+      #elftosb2 -z -c ./uboot_prebuilt.db -o i$(ARCH)_uboot.sb
++      #elftosb -z -c ./uboot.bd -o i$(ARCH)_uboot.sb
++      #elftosb -z -f imx28 -c ./uboot_ivt.bd -o i$(ARCH)_ivt_uboot.sb
  endif
        #@echo "generating kernel bootstream file sd_mmc_bootstream.raw"
        #Please use cfimager to burn xxx_linux.sb. The below way will no
index 5cf48fd6fc846a38d9dbbe70cc236d4d071be5d4..afd4150248e68d95e29415b243e8739038964c11 100644 (file)
@@ -1,5 +1,5 @@
---- a/linux_prebuilt.db
-+++ b/linux_prebuilt.db
+--- a/linux_ivt.bd
++++ b/linux_ivt.bd
 @@ -4,10 +4,10 @@ options {
        flags = 0x01;
  }
@@ -7,11 +7,11 @@
 -      power_prep="./power_prep/power_prep";
 -      sdram_prep="./boot_prep/boot_prep";
 -      linux_prep="./linux_prep/output-target/linux_prep";
--      zImage = "./zImage";
+-      zImage="./zImage";
 +      power_prep="./power_prep";
 +      sdram_prep="./boot_prep";
 +      linux_prep="./linux_prep";
-+      zImage = "./zImage_dtb";
++      zImage="./zImage_dtb";
  }
  
  section (0) {
index 6ed57863444553e0a63050220bfda3b6a408ce2e..dd0a5ce4783f4bc3f5e79a26fa9aae414fdbbfe1 100644 (file)
  
  all: build_prep gen_bootstream
  
-@@ -94,6 +97,8 @@ distclean: clean
+@@ -101,6 +104,8 @@ distclean: clean
  clean:
        -rm -rf *.sb
        rm -f sd_mmc_bootstream.raw
        $(MAKE) -C linux_prep clean ARCH=$(ARCH)
        $(MAKE) -C boot_prep clean ARCH=$(ARCH)
        $(MAKE) -C power_prep clean ARCH=$(ARCH)
---- a/uboot.db
-+++ b/uboot.db
-@@ -3,7 +3,7 @@
- sources {
-       power_prep="./power_prep/power_prep";
-       sdram_prep="./boot_prep/boot_prep";
--      image="/home/b18647/repos/ltib_latest/rootfs/boot/u-boot";
-+      image="../boot/u-boot";
- }
- section (0) {
diff --git a/package/boot/imx-bootlets/patches/004-fix-ARM-8933_1.patch b/package/boot/imx-bootlets/patches/004-fix-ARM-8933_1.patch
new file mode 100644 (file)
index 0000000..3b896b2
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/linux_prep/core/cmdlines.S
++++ b/linux_prep/core/cmdlines.S
+@@ -14,7 +14,7 @@
+ #define CMDLINES_FILE "output-target/command_lines_stripped.txt"
+ #endif
+-      .section .cmdlines, #alloc
++      .section .cmdlines, "a"
+       .globl  cmdlines_start
+ cmdlines_start:
+       .incbin CMDLINES_FILE