kernel: netdevices: add RmNet MAP support
authorRobert Marko <robert.marko@sartura.hr>
Mon, 7 Oct 2024 13:07:39 +0000 (15:07 +0200)
committerRobert Marko <robert.marko@sartura.hr>
Wed, 9 Oct 2024 19:21:57 +0000 (21:21 +0200)
RmNet driver provides a transport agnostic MAP (multiplexing and
aggregation protocol) support in embedded module. Module provides
virtual network devices which can be attached to any IP-mode
physical device.

This is commonly used on Qualcomm based modems for data aggregation.

Signed-off-by: Robert Marko <robert.marko@sartura.hr>
package/kernel/linux/modules/netdevices.mk

index d77dabfa79b6dbf9d9458ee4cbadb73b06cc106f..1470c5c1761046f50142ae6550f81c0a01516e09 100644 (file)
@@ -801,6 +801,23 @@ endef
 $(eval $(call KernelPackage,r6040))
 
 
+define KernelPackage/rmnet
+  SUBMENU:=$(NETWORK_DEVICES_MENU)
+  TITLE:=RmNet MAP support
+  KCONFIG:=CONFIG_RMNET
+  FILES:=$(LINUX_DIR)/drivers/net/ethernet/qualcomm/rmnet/rmnet.ko
+  AUTOLOAD:=$(call AutoLoad,30,rmnet)
+endef
+
+define KernelPackage/rmnet/description
+  Kernel support for RMNET module which is used for handling data in the
+  multiplexing and aggregation protocol (MAP) format in the embedded data
+  path. RMNET devices can be attached to any IP mode physical device.
+endef
+
+$(eval $(call KernelPackage,rmnet))
+
+
 define KernelPackage/niu
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=Sun Neptune 10Gbit Ethernet support