projects
/
openwrt
/
staging
/
lynxis.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
b18f75c
)
build: add image command for calling kernel2minor
author
Felix Fietkau
<nbd@nbd.name>
Fri, 6 Jan 2017 15:49:52 +0000
(16:49 +0100)
committer
Felix Fietkau
<nbd@nbd.name>
Sat, 7 Jan 2017 16:50:54 +0000
(17:50 +0100)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/image-commands.mk
patch
|
blob
|
history
diff --git
a/include/image-commands.mk
b/include/image-commands.mk
index 083a3890316c633e9a1ffaab6bd7790ebb29ea34..a7acd0ee6739e11cd04c9353f1352c91fe1d54f1 100644
(file)
--- a/
include/image-commands.mk
+++ b/
include/image-commands.mk
@@
-190,3
+190,8
@@
metadata_json = \
define Build/append-metadata
$(if $(SUPPORTED_DEVICES),echo $(call metadata_json,$(SUPPORTED_DEVICES)) | fwtool -I - $@)
endef
+
+define Build/kernel2minor
+ kernel2minor -k $@ -r $@.new $(1)
+ mv $@.new $@
+endef