iodine: Cleanup package Makefile
authorVasilis Tsiligiannis <acinonyx@openwrt.gr>
Sat, 30 Oct 2010 19:25:25 +0000 (19:25 +0000)
committerVasilis Tsiligiannis <acinonyx@openwrt.gr>
Sat, 30 Oct 2010 19:25:25 +0000 (19:25 +0000)
SVN-Revision: 23721

net/iodine/Makefile

index f11ad0b5c9d8511602ee9bae53820e35ea7dd402..fa90f3b350106845e7a87021bd915c761c19f4e2 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iodine
 PKG_VERSION:=0.6.0-rc1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://code.kryo.se/iodine/
@@ -20,7 +20,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/iodine/Default
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+zlib +kmod-tun
+  DEPENDS:= +kmod-tun
   TITLE:=IP over DNS tunneling
   URL:=http://code.kryo.se/iodine/
 endef
@@ -46,14 +46,6 @@ endef
 define Build/Configure
 endef
 
-define Build/Compile
-       $(call Build/Compile/Default,\
-               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -c -DLINUX" \
-               LDFLAGS="$(TARGET_LDFLAGS) -lz" \
-               all \
-       )
-endef
-
 define Package/iodine/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/iodine $(1)/usr/sbin