projects
/
openwrt
/
staging
/
zorun.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
849ff98
)
rules.mk: add _dsp to ARCH_SUFFIX if the dsp ase is used
author
John Crispin
<john@openwrt.org>
Mon, 6 May 2013 16:45:51 +0000
(16:45 +0000)
committer
John Crispin
<john@openwrt.org>
Mon, 6 May 2013 16:45:51 +0000
(16:45 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 36566
rules.mk
patch
|
blob
|
history
diff --git
a/rules.mk
b/rules.mk
index 2333f2aaf5d1acacedc603a371178bb60a0e82a1..b9510057b64c08a18729367cb406b1fd7689ec6d 100644
(file)
--- a/
rules.mk
+++ b/
rules.mk
@@
-63,6
+63,12
@@
endif
ifneq ($(filter -mips%r2,$(TARGET_OPTIMIZATION)),)
ARCH_SUFFIX:=_r2
endif
+ifneq ($(filter -mdsp,$(TARGET_OPTIMIZATION)),)
+ ARCH_SUFFIX:=$(ARCH_SUFFIX)_dsp
+endif
+ifneq ($(filter -mdspr2,$(TARGET_OPTIMIZATION)),)
+ ARCH_SUFFIX:=$(ARCH_SUFFIX)_dspr2
+endif
ifdef CONFIG_USE_MIPS16
TARGET_OPTIMIZATION+= -minterlink-mips16 -mips16
endif