gnutls: Do not try to install gnutls-cli or server when OCSP is disabled.
authorFlorian Fainelli <florian@openwrt.org>
Tue, 20 May 2014 04:51:47 +0000 (04:51 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 20 May 2014 04:51:47 +0000 (04:51 +0000)
These tools aren't compiled in that case.

Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
[florian: fix subject]
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 40796

libs/gnutls/Makefile

index 997532bdfc66cce417afa44b7927d565f6236629..9544ffb0c366bb4f372980be5d30232a4632758a 100644 (file)
@@ -190,10 +190,12 @@ endef
 
 define Package/gnutls-utils/install
        $(INSTALL_DIR) $(1)/usr/bin
+ifeq ($(CONFIG_GNUTLS_OCSP),y)
+ifeq ($(CONFIG_GNUTLS_ANON),y)
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/bin/gnutls-{cli,serv} \
                $(1)/usr/bin/
-ifeq ($(CONFIG_GNUTLS_OCSP),y)
+endif
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/bin/ocsptool \
                $(1)/usr/bin/