f2fs-tools: Add missing 'f2fslabel' symlink
authorSean Khan <datapronix@protonmail.com>
Mon, 1 Jul 2024 17:59:45 +0000 (13:59 -0400)
committerRobert Marko <robimarko@gmail.com>
Wed, 3 Jul 2024 09:14:42 +0000 (11:14 +0200)
`f2fslabel` is already built into `f2fs.fsck`, but is missing its symlink
in the final package.

Signed-off-by: Sean Khan <datapronix@protonmail.com>
Link: https://github.com/openwrt/openwrt/pull/15851
Signed-off-by: Robert Marko <robimarko@gmail.com>
package/utils/f2fs-tools/Makefile

index d5dc1a6d7824a1a7c32d68fe3701c1f7f29d0047..d11e89d8e3cee2e0907cbe5585e3ed1d2bb00fec 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=f2fs-tools
 PKG_VERSION:=1.16.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/f2fs-tools.git/snapshot/
@@ -137,6 +137,7 @@ define Package/f2fsck/install
        $(LN) ../sbin/fsck.f2fs $(1)/usr/sbin/dump.f2fs
        $(LN) ../sbin/fsck.f2fs $(1)/usr/sbin/sload.f2fs
        $(LN) ../sbin/fsck.f2fs $(1)/usr/sbin/resize.f2fs
+       $(LN) ../sbin/fsck.f2fs $(1)/usr/sbin/f2fslabel
 endef
 
 Package/f2fsck-selinux/install = $(Package/f2fsck/install)