update to the latest git commit to include fix for resources leak on mod_blacklist...
authorMazi Lo <OpenWRT@slickdeals.endjunk.com>
Wed, 21 Sep 2011 17:04:50 +0000 (17:04 +0000)
committerMazi Lo <OpenWRT@slickdeals.endjunk.com>
Wed, 21 Sep 2011 17:04:50 +0000 (17:04 +0000)
SVN-Revision: 28281

net/freeswitch/Makefile
net/freeswitch/files/etc.minimal/autoload_configs/modules.conf.xml
net/freeswitch/files/etc.packages/blacklist/autoload_configs/blacklist.conf.xml [new file with mode: 0644]
net/freeswitch/files/etc.packages/blacklist/blacklists/blocked.list [new file with mode: 0644]

index a4dd797593daf75fe4ea674a5263dc1133368442..66e5647a02cf5c7c7838c7d6da3d7c6df65c74a8 100644 (file)
@@ -16,7 +16,7 @@ PKG_RELEASE:=1
 #
 # The latest FS git hash in PKG_REV can be obtained from http://fisheye.freeswitch.org
 #
-PKG_REV:=379c9fc41dd0196ccd7bf9640ae704b995cbc15e
+PKG_REV:=5fe3a22d83867d07f30ef7974329b2fa966747ea
 PKG_SOURCE_VERSION:=$(PKG_REV)
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://git.$(PKG_NAME).org/$(PKG_NAME).git
index e73a07cdf92b917fdf3340d77b82e5dfabe16d70..452d79f675e5cdcd3aeb594ad174b9166b1dc0b9 100644 (file)
@@ -4,7 +4,7 @@
     <!-- Loggers (I'd load these first) -->
     <load module="mod_console"/>
     <load module="mod_logfile"/>
-    <load module="mod_syslog"/>
+    <!-- <load module="mod_syslog"/> -->
 
     <!--<load module="mod_yaml"/>-->
 
@@ -18,7 +18,7 @@
     <!-- <load module="mod_xml_cdr"/> -->
 
     <!-- Event Handlers -->
-    <!-- <load module="mod_cdr_csv"/> -->
+    <load module="mod_cdr_csv"/>
     <!-- <load module="mod_cdr_sqlite"/> -->
     <!-- <load module="mod_event_multicast"/> -->
     <load module="mod_event_socket"/>
@@ -31,7 +31,7 @@
     <!-- <load module="mod_ldap"/> -->
 
     <!-- Endpoints -->
-    <load module="mod_dingaling"/>
+    <!-- <load module="mod_dingaling"/> -->
     <!-- <load module="mod_portaudio"/> -->
     <!-- <load module="mod_alsa"/> -->
     <load module="mod_sofia"/>
     <!-- <load module="mod_unicall"/> -->
     <!-- <load module="mod_skinny"/> -->
     <!-- <load module="mod_khomp"/>   -->
+    <!-- <load module="mod_rtmp"/>   -->
 
     <!-- Applications -->
     <load module="mod_commands"/>
-    <!-- <load module="mod_conference"/> -->
+    <load module="mod_conference"/>
     <load module="mod_db"/>
     <load module="mod_dptools"/>
     <!-- <load module="mod_expr"/> -->
     <!-- <load module="mod_timerfd"/> -->
 
     <!-- Languages -->
-    <load module="mod_lua"/>
     <!-- <load module="mod_spidermonkey"/> -->
     <!-- <load module="mod_perl"/> -->
     <!-- <load module="mod_python"/> -->
     <!-- <load module="mod_java"/> -->
+    <load module="mod_lua"/>
 
     <!-- ASR /TTS -->
     <!-- <load module="mod_flite"/> -->
 
     <!-- Third party modules -->
     <!--<load module="mod_nibblebill"/>-->
+    <!--<load module="mod_callcenter"/>-->
 
   </modules>
 </configuration>
diff --git a/net/freeswitch/files/etc.packages/blacklist/autoload_configs/blacklist.conf.xml b/net/freeswitch/files/etc.packages/blacklist/autoload_configs/blacklist.conf.xml
new file mode 100644 (file)
index 0000000..33be75d
--- /dev/null
@@ -0,0 +1,11 @@
+<configuration name="mod_blacklist.conf" description="Blacklist module">
+<lists>
+       <!--
+               Example blacklist, the referenced file contains blacklisted items, one entry per line
+
+               NOTE: make sure the file exists and is readable by FreeSWITCH.
+       -->
+
+       <list name="blocked" filename="/etc/freeswitch/blacklists/blocked.list"/>
+</lists>
+</configuration>
diff --git a/net/freeswitch/files/etc.packages/blacklist/blacklists/blocked.list b/net/freeswitch/files/etc.packages/blacklist/blacklists/blocked.list
new file mode 100644 (file)
index 0000000..e69de29